0

compton.conf not work on ubuntu | XFCE

*i've done use sample.conf and some friend config

abdipn@indoxploit:~$ compton --backend glx --config ~/.compton.conf

Error when reading configuration file "/home/abdipn/.compton.conf", line 45: syntax error

    # Shadow
shadow = true;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
shadow-radius = 5;
shadow-offset-x = -7;
shadow-offset-y = -7;
shadow-opacity = 0.7;
shadow-red = 0.4;
shadow-green = 0.4;
shadow-blue = 0.4;
shadow-exclude = [
#    "! name~=''",
#    "name = 'Notification'",
#    "name = 'Dunst'",
#    "name = 'Plank'",
#    "name = 'Docky'",
#    "name = 'Kupfer'",
#    "name = 'xfce4-notifyd'",
#    "name = 'dmenu'",
#    "name = 'dmenu_run'",
#    "name *= 'VLC'",
#    "name *= 'compton'",
#    "name *= 'Chromium'",
#    "name *= 'Chrome'",
#    "name *= 'polybar'",
#    "class_g = 'Conky'",
#    "class_g = 'Kupfer'",
#    "class_g = 'Synapse'",
#    "class_g ?= 'Notify-osd'",
#   "class_g ?= 'Cairo-dock'",
#    "class_g ?= 'Xfce4-notifyd'",
#    "class_g ?= 'Xfce4-power-manager'",
#   "_NET_WM_STATE@:32a *= '_NET_WM_STATE_HIDDEN'",
#    "_GTK_FRAME_EXTENTS@:c",
#   "!focused"
#];
# shadow-exclude = "n:e:Notification";
# shadow-exclude-reg = "x10+0+0";
# xinerama-shadow-crop = true;

# Opacity
#menu-opacity = 1;
inactive-opacity = 1;
active-opacity = 1;
frame-opacity = 0;
inactive-opacity-override = true;
alpha-step = 0.06;
inactive-dim = 0.1;
inactive-dim-fixed = true;
blur-background = true;
blur-background-frame = true;
blur-method="kawase";
blur-kern = "3x3box";
blur-strength = 5;
blur-background-fixed = true;
blur-background-exclude = [
    "window_type = 'dock'",
    "window_type = 'desktop'",
    "_GTK_FRAME_EXTENTS@:c",
    "class_g = 'firefox'",
    "class_g = 'Firefox'",
    "class_g = 'qutebrowser'",
    "class_g = 'feh'"
];
opacity-rule = [ 
    "80:class_g = 'URxvt'",
    "80:class_g = 'Gnome-terminal'",
    "85:class_g = 'Nautilus'",
    "85:class_g = 'Thunar'",
    "85:class_g = 'Transmission-gtk'",
    "0:_NET_WM_STATE@:32a *= '_NET_WM_STATE_HIDDEN'"
];

# Fading
fading = true;
# fade-delta = 30;
fade-in-step = 0.1;
fade-out-step = 0.1;
# no-fading-openclose = true;
# no-fading-destroyed-argb = true;
fade-exclude = [ ];

# Other
backend = "glx";
mark-wmwin-focused = true;
mark-ovredir-focused = true;
# use-ewmh-active-win = true;
detect-rounded-corners = true;
detect-client-opacity = true;
refresh-rate = 00;
vsync = "opengl-oml";
# dbe = true;
paint-on-overlay = true;
# sw-opti = true;
unredir-if-possible = true;
# unredir-if-possible-delay = 5000;
# unredir-if-possible-exclude = [ ];
focus-exclude = [ "class_g = 'Cairo-clock'" ];
detect-transient = true;
detect-client-leader = true;
invert-color-include = [ ];
# resize-damage = 1;

# GLX backend
glx-no-stencil = true;
# glx-copy-from-front = false;
glx-use-copysubbuffermesa = true;
glx-swap-method = 3
glx-no-rebind-pixmap = true;
# glx-swap-method = "copy";
# glx-use-gpushader4 = true;
# xrender-sync = true;
# xrender-sync-fence = true;

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = true; opacity = 0.75; focus = true; };
};
1

It looks like in your line 13, shadow-exclude = [ doesn't have a closing square brace, I'd just comment out that line

| improve this answer | |
  • wow ! thanks ! its work xD you save my life, thanks a lot – Abigail Jelsford Nov 20 '18 at 5:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.