-1

I can't find any infos on how to update PHP 5.5.14 to the latest PHP 5.6.37 which was released on 19 Jul 2018.

I executed apt-get update and apt-get upgrade but PHP 5.5.14 is still installed.

OS: openSUSE Leap version 42.3

  • You should migrate to PHP 7.2 as soon as possible, as support for 5.6 ends on Dec 31st. – RoVo Nov 19 '18 at 9:51
  • Do you use SuSE or Debian/Ubuntu? There is discrepancy between your question and tags – Romeo Ninov Nov 19 '18 at 9:52
  • 1
    Which OS, which version? apt-get indicates your using a Debian / Debian-derived Linux. But all still supported Debian/Ubuntu/Mint etc. variants should have 5.6 and 7.2 or only 7.2. So I think you have a problem with your OS. Find out with cat /etc/os-release or hostnamectl and edit your question adding that information. – RoVo Nov 19 '18 at 10:00
  • @RomeoNinov I am using Suse and what discrepancy do you mean exactly? – Black Nov 19 '18 at 10:11
  • @RoVo, Thats not possible. I am using Magento 1.8 which only supports php 5. – Black Nov 19 '18 at 10:11
0

You can build php on your own and use --with-prefix or --prefix, i.e. /usr/local/php.

If you are not sure what to put behind ./configure command you can copy it from current PHP, it is visible in phpinfo() (compiled with...).

Just, don't forget to use --prefix switch for configure.

0

You can search for openSUSE packages on software.opensuse.org, you should land here. This would show you a non-official build, so be very careful and make sure you can roll back to a previous state. If you decide to give it a try, add the respective repo to your system and try to install a newer version.

# Add repo
zypper addrepo https://download.opensuse.org/repositories/Cloud:/Platform:/buildpacks:/dependencies/openSUSE_Leap_42.3/ php-5

# List php-5 packages
zypper se -s php-5  

Loading repository data...
Reading installed packages...

S  | Name       | Type       | Version    | Arch   | Repository
---+------------+------------+------------+--------+-----------
   | php-5.6.37 | srcpackage | 5.6.37-1.1 | noarch | php-5.6   
i+ | php-5.6.37 | package    | 5.6.37-1.1 | x86_64 | php-5.6   
   | php-5.6.38 | srcpackage | 5.6.38-1.1 | noarch | php-5.6   
   | php-5.6.38 | package    | 5.6.38-1.1 | x86_64 | php-5.6   

There's a newer version available, so install it:

zypper in php-5.6.38

The following NEW package is going to be installed:
  php-5.6.38

1 new package to install.
Overall download size: 2.2 KiB. Already cached: 0 B. No additional space will be used or freed after the operation.
Continue? [y/n/...? shows all options] (y):

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.