0

I am unable to send my desktop capture to a localhost ffserver: the connection to the local server is refused.

# ffserver >/dev/null 2>&1 &
# ffmpeg -video_size 1600x900 -framerate 20 -f x11grab -i :0.0 \
 -f alsa -ac 2 -i hw:0 http://localhost:8090/feed1.ffm
....
[tcp @ 0x56514ba629e0] Connection to tcp://localhost:8090 failed (Connection refused
), trying next address

I have tried to add the option ACL allow 192.168.0.0 192.168.255.255 in /etc/ffserver.conf without success

What are the reasons that perclude me from sending my video to http://localhost:8090/feed1.ffm

0

Try useing these ACL settings:

ACL allow 127.0.0.1
ACL allow 192.168.0.0 192.168.255.255

With this Command:

ffserver >/dev/null 2>&1 &
ffmpeg -video_size 1600x900 -framerate 20 -f x11grab -i :0.0 \
-f alsa -ac 2 -i hw:0 http://127.0.0.1:8090/feed1.ffm

It seems as though the connection may be being refused because of the word localhost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.