2

Backstory: So, I have a vm running and managed to open enough browser tabs to make linux mint freeze completely, by filling up both swap and ram. Then swappiness was at 60. So after this happened a few times, I booted from a live cd, shrank my main ext4 partition, and increased my swap from like 5gb to 21ish. Rebooted and changed swappiness to 100.

Still not doing as expected.

Now swap REFUSES to be used at all, and stays around 0.2% in system monitor and free never changes much more than 100 or so MB.

I have tried the original 60 swappiness setting. I am using a ryzen cpu and have 16gb of ram. I have the 4.19 kernel, but also tried the 4.15 that mint ships with, still doesnt fill swap.

Does the swap partition have to be less than my ram for it to be used? If so can I use multiple swap partitions to work around this? I understand that not all memory can be swapped, but it went from 4+ gb filled to the point of OOM to not filling at all basically (and still OOM-ing)

I have tried swaping off and back on, I've tried zeroing the partiton with dd and mkswaping again same behaviour.

UPDATE:

neo@NErdbOx:~$ ls -l /proc/sys/vm/swappiness
-rw-r--r-- 1 root root 0 Nov 21 05:54 /proc/sys/vm/swappiness
neo@NErdbOx:~$ free
              total        used        free      shared  buff/cache   available
Mem:       16371488     4300768     1626640      237700    10444080    11496096
Swap:      20395004           0    20395004
neo@NErdbOx:~$ cat /proc/sys/vm/swappiness
100

UPDATE 2: filled memory using

   stress --vm-bytes $(awk '/MemAvailable/{printf "%d\n", $2 * 0.9;}' < /proc/meminfo)k --vm-keep -m 1

result of free, still barely any swap used:

                  total        used        free      shared  buff/cache   available
    Mem:       16371488    14720040      201460      240368     1449988     1100576
    Swap:      20395004       11520    20383484
  • Could you post a copy of your fstab? cat /etc/fstab – Michael Prokopec Nov 21 '18 at 12:07
  • pastebin.com/x8Yx1c7Q here ya go, uuid matches, for a while i had it commented out and was manually doing it at boot to troubleshoot too\ – Julian Barber Nov 21 '18 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.