11

I'm using Linux Mint 13 KDE. I installed a TrueType font that I have and like (Arrus BT). I've noticed that the font rendering is noticeably worse on Linux. If I set hinting to none or slight, the letters appear slightly fuzzy and there is poor contrast. If I set hinting to full, the letters appear slightly chunky in shape, but the lines are unappealingly thin. In both cases the letters seem too "light", alhtough in the first case it's because they seem to be blurred too much with the background, and in the second case it's because the lines are too thin.

I have seen various other postings like this and a few like this that advocate fiddling with .fonts.conf in a way that seems to be outdated (I can set those settings in the System Settings panel). I've also tried the "autohint" option described for instance here. None of these produce what I want.

For an illustration, here is the font rendering on Linux with no hinting:

No hinting

Here it is with full hinting:

No hinting

And here it is on Windows:

No hinting

I've used this color scheme because the problem is most pronounced with this sort of situation, where the text is a brighter color on a dark background. I've tried intermediate hinting options, all of which suffer from basically the same problem (too blurry or too thin). I've also tried the various subpixel smoothing options (RGB, BGR, etc.), which don't seem to have an appreciable effect on resolving the problem.

I see from previous posts on this issue that there are differences of opinion on what "looks best" in terms of font hinting and smoothing. Putting all that aside, my question is simple: is there or is there not a way to get Linux to display the font so it looks like it does in Windows, and if so, how?

  • Not really an answer, but the information here and here may be useful. – terdon Sep 16 '12 at 16:43
  • Looks mostly like different fonts to my (untrained) eyes... – vonbrand Mar 4 '14 at 18:13
  • They are the same font. – BrenBarn Mar 4 '14 at 18:44
3

Subpixel smoothing can improve rendering slightly, but not 100% windows-like. Maybe you should try infinality patches?

0

Try the solution below for blurry or broken fonts: http://lampjs.wordpress.com/2014/09/12/arch-linux-kde-blurry-broken-fonts/

excerpt
  1. go to system settings ->application preference
  2. in fine tuning select “High display resolution and High CPU”
  3. click on fonts in left side bar
  4. check the “Force fonts DPI”

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.