19

After the last upgrade on:

  Operating System: Debian GNU/Linux buster/sid
            Kernel: Linux 4.18.0-2-686-pae
      Architecture: x86

/usr/lib/tracker/tracker-store eats a huge load of CPU.

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND                                                                          
 7039 nath      20   0   96136  24460  11480 R 100,0   1,3   0:01.76 tracker-store

When I run tracker daemon I get:

Miners:
17 Nov 2018, 21:17:06:  ?     File System           - Not running or is a disabled plugin
17 Nov 2018, 21:17:06:  ?     Applications          - Not running or is a disabled plugin
17 Nov 2018, 21:17:06:  ?     Extractor             - Not running or is a disabled plugin

I thought I disabled all tracker activities, what is it doing?

The fan is going like crazy and a reboot does not improve the situation.

23

after having tracker-store running with almost 100% CPU, almost all the time for 7 days now, it seems like I found an easy fix:

tracker reset --hard

CAUTION: This process may irreversibly delete data.
Although most content indexed by Tracker can be safely reindexed, it can?t be assured that this is the case for all data. Be aware that you may be incurring in a data loss situation, proceed at your own risk.

Are you sure you want to proceed? [y|N]: 

/usr/lib/tracker/tracker-store process is gone for now, fan is spinning down, and everything seems quiet after a week. Haven't tested a reboot though...


Update: fixed, also after a reboot tracker-store stays quiet.

| improve this answer | |
  • 3
    this worked for me flawlessly !!!! beautiful solution .. ubuntu 20.04 – Mr.P Apr 22 at 10:58
  • 3
    Note to others coming here: sudo tracker reset --hard does not help; make sure to run this as yourself. (I know that's what the answer says but I ran it with sudo by habit.) – GaryO May 21 at 12:25
5

tracker-store is part of tracker, a program that scans certain specified locations on your hard drive (and other places like your emails) and indexes the contents into a database. This allows you to do fast file contents searches. Whereas, tracker-miner-* are programs that scan data and tracker-store is the program that stores the metadata in a database for fast access later. Tracker uses a database for its own purposes, so it makes sense that it can use your CPU even when you are not dealing with process.

You could also configure tracker to index nothing (see program tracker-preferences), thereby probably stopping it from doing any work at all. Or you could try removing the package entirely, but, this will most likely break your system (more details - thanks to @broman). And also check this post How do I disable tracker in GNOME?.

Source :

blogs.gnome.org/mr/2009/09/18/tracker-update-2
What is a tracker? - gnome

| improve this answer | |
  • 1
    thanks for the link, I thought I disabled it completely, so it seems I only disabled the miners. What is not clear to me is that it has to be done at some point, but it runs almost 100% the whole time. I'm actually rather guessing it is some kind of bug. – nath Nov 18 '18 at 19:12
  • @nath I thought that you should ask wether this is a bug or not? on debian users mailing list ( debian-user@lists.debian.org ). list web-page : lists.debian.org/debian-user – finn Nov 18 '18 at 19:37
  • 1
    @VipulKumar I think you should add that it will most likely break your system to uninstall, since nautilus (and possibly others) depends on tracker. See more here: soimort.org/notes/171103 – klutt Nov 19 '18 at 15:26
  • @Broman, Thanks for pointing out, I will change modify my post. – finn Dec 5 '18 at 19:45
2

Some tracker miners get hung up on content they don't understand. If tracker daemon -f isn't showing any updates but tracker-extract is still hogging the CPU, maybe take a look in /tmp/tracker-extract-files.*. If the same symlink sits around there for any length of time, it's crashed the miner process. It's important to remove that file from anywhere that tracker will find it, as otherwise it'll crash again.

(a summary of my response originally here: no progress updates from gnome tracker)

| improve this answer | |
  • I find tracker's indexing functions too useful to remove from my system, so I put up with its foibles – scruss Jun 22 '19 at 20:17
2

System Ubuntu 20.04.1 LTS Gnome 3.36.3

tried most of the easy solutions over the years from Ubuntu 18 on;

$ tracker daemon -t 

every time after login and repeat a few times for good measure, this would shut tracker down for the session.

also

$ tracker reset -r

and disable search in gsettings

tracker would never give up

I stumbled upon /etc/systemd/user/default.target.wants and changed the tracker-extract.service and tracker-miner-fs.service names by adding .dis to the end of the filename and did a reboot too see what happened ; nothing... as in no tracker running

$ tracker daemon -t
0 PID's found

I have not experienced any adverse effect so far (2.5 days + multiple reboots). My requirements are modest so is my linux knowledge so I can't state that this blunt chopping will not affect your installation in a bad way.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.