1

I recently launched a game that decided to set my resolution to 800x600, go fullscreen, and then freeze. After force-killing the game, to my joy, I was met with a panning 800x600 desktop, and had to re-learn how to use xrandr so I could set my desktop back to a reasonable resolution.

But it seems that the ghost of that game still lingers on my system, as I just noticed that two of my frequently-used programs are suddenly impossible to comprehend. It's hard to describe with words, so how about some screenshots:

teeny dmenu teeny gimp + normal dwm

dmenu and gimp are rendering their UI so small that it's incomprehensible. What's perplexing is that the window manager (DWM, normal font) is rendering that same font just fine. And other programs (like st and xfe) also are working fine.

I have no idea what to do. Fonts are not my strong suit, and I'm afraid that if I reboot, the issue won't resolve itself and my window manager will join the tiny fonts club. I don't know what GTK+ uses for UI fonts, but dmenu uses Xft (X11). How can I make my UI readable again?

  • Can someone explain the "too broad" vote to close? How is this too broad? I'm having a very specific issue with my system fonts and am asking for help. That is not broad – Braden Best Nov 17 '18 at 21:00
  • 1
    Different OS, but similar question: unix.stackexchange.com/questions/521832/… – Michael Scheper May 29 at 20:13
  • I forgot that I asked this. I did actually find a solution some time later. Let me answer my own question – Braden Best May 29 at 22:20
0

I forgot that I posted this question. I actually did end up finding a solution, which I put in a shell script aptly named unfuckdesktop:

$ cat unfuckdesktop
#!/bin/sh
mon=DVI-I-1
xrandr --output $mon --scale 1x1 --panning 0x0 --mode 1920x1080

Replace DVI-I-1 with whatever xrandr (without arguments) spits back.

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected primary (normal left inverted right x axis y axis)
DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 544mm x 303mm
   1920x1080     60.00*+ 239.76   143.98   119.98    59.94    50.00    60.00    50.04
   1600x900      60.00
   1280x1024     75.02    60.02
   1280x720      59.94    50.00
   1152x864      75.00
   1024x768      75.03    60.00
   800x600       75.00    60.32
   ...

Note where it says "connected"

DVI-I-1 connected 1920x1080+0+0

That said, when I executed this, it fixed the small text. It was a while ago, so I don't remember exactly which parameter it was, but it's probably --scale 1x1.

It's also possible that I didn't put it in there. I'm pretty sure that I did, since that problem plagued me for a good while, but if you're experiencing tiny-text and the above solution doesn't work, you can also try --dpi.

xrandr --output $mon --dpi 90

IIRC, the last time I messed with my DPI settings, I set it to 90.

  • For me, xrandr without params says Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 345mm x 194mm and many more lines. So I tried xrandr --output 3840x2160+0+0 --scale 1x1 --panning 0x0 --mode 1920x1080 and it said warning: output 3840x2160+0+0 not found; ignoring. I guess I need to read more about xrandr, but if you have any more advice, please let me know. Thanks! – Michael Scheper May 31 at 19:56
  • @michaelscheper The device is eDP-1, not 3840x2160+0+0. So you want xrandr --output eDP-1 ... – Braden Best Jun 1 at 15:52
  • That worked, except I'm not sure about the --mode parameter. My screen resolution, which I want to maintain, is 3840×2160, but --mode 3840x2160 and --mode 3840x2160+0+0 returned xrandr: cannot find mode 3480x2160. I also tried --mode 1920x1080, but that changed my screen resolution, which I don't want. And they physical size of my screen is indeed 348×194mm, so the original mode does seem correct. I'm beginning to wonder if I'm barking up the wrong tree here. – Michael Scheper Jun 3 at 16:41
  • I tried leaving --mode off, and just playing just with --scale. This affects all my applications, not just the problematic ones—did you find it only affected the tiny apps? I'm beginning to think their sizes are just hard-coded in pixels, and that they're just not aware of their physical size on the screen. – Michael Scheper Jun 3 at 16:49
  • @MichaelScheper run xrandr without arguments and send me a pastebin link to the output – Braden Best Jun 3 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.