0

I currently have sendmail configured on a web server, and only need to send emails for newsletters, contact forms, notifications, any e-mail address using a domain hosted on the server fails to send. We are using another server on a different IP address for e-mail, and I've tried using that as a relay but ran into the same issue. Additionally, the e-mail address is getting replaced with the FQDN.

Before I tried relaying to our mail server, I could successfully send to any domain, but had the same issue with the hostname of the webserver being added the email address (user@domain.com would be changed to user@host1.domain.com)

Here is the current error: 050 550 5.1.1 : Recipient address rejected: User unknown in local recipient table 050 554 5.5.1 Error: no valid recipients

Any ideas?

0

This may or may not help. It is my understanding that the server is just seeing the incoming mail as comming from an invalid sender for some reason. The issue with the adding of the hostname is most likely comming from the server not knowing the format you wish to have the mail processed too. Also this might help: https://access.redhat.com/documentation/en-us/red_hat_network_satellite/5.0/html/installation_guide/s1-installation-sendmail. Let me know if that helped.

  • I'll give that a try. So even though I can receive e-mail sent to the same addresses normal (via e-mail clients, webmail, etc), when it is sent to the mail server from the web server that e-mail is considered invalid and the problems start? It would seem like all mail I try to send from the web server would fail, which isn't the case. I can send to say, gmail, through the command line or web application without any issues. – Natrix Nov 18 '18 at 0:14
  • It looks like the suggestions you mentioned wouldn't apply for me. I already had the changes for sendmail.mc applied and am no using smrsh. – Natrix Nov 18 '18 at 0:26
  • Sorry I could not help, good luck with finding a fix. – Michael Prokopec Nov 18 '18 at 0:42
  • O in that sendmail.mc file is MAILER(`local') set if not it may be rejecting it based on the fact it looks to be coming from it's self and it is not set to recieve localy. – Michael Prokopec Nov 18 '18 at 0:50
  • This may also help: ghacks.net/2009/06/05/… – Michael Prokopec Nov 18 '18 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.