13

I am using nmcli on ArchLinux (version 1.14.5dev+17+gba83251bb-1 from the official package repository) to connect to wifi. This works perfectly for all wireless networks apart from this one Vodafone EasyBox network.

Trying to activate the connection with the correct password gives me the following error message:

Passwords or encryption keys are required to access the wireless network 'EasyBox-123456'.
Warning: password for '802-11-wireless-security.psk' not given in 'passwd-file' and nmcli cannot ask without '--ask' option.
Error: Connection activation failed: Secrets were required, but not provided

However, 802-11-wireless-security.psk is stored, as you can see here:

$ nmcli con show EasyBox-123456
connection.id:                          EasyBox-123456
connection.uuid:                        <hidden>
connection.stable-id:                   --
connection.type:                        802-11-wireless
connection.interface-name:              --
connection.autoconnect:                 yes
connection.autoconnect-priority:        0
connection.autoconnect-retries:         -1 (default)
connection.multi-connect:               0 (default)
connection.auth-retries:                -1
connection.timestamp:                   0
connection.read-only:                   no
connection.permissions:                 --
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 --
connection.gateway-ping-timeout:        0
connection.metered:                     unknown
connection.lldp:                        default
connection.mdns:                        -1 (default)
connection.llmnr:                       -1 (default)
802-11-wireless.ssid:                   EasyBox-123456
802-11-wireless.mode:                   infrastructure
802-11-wireless.band:                   --
802-11-wireless.channel:                0
802-11-wireless.bssid:                  --
802-11-wireless.rate:                   0
802-11-wireless.tx-power:               0
802-11-wireless.mac-address:            <hidden>
802-11-wireless.cloned-mac-address:     --
802-11-wireless.generate-mac-address-mask:--
802-11-wireless.mac-address-blacklist:  --
802-11-wireless.mac-address-randomization:default
802-11-wireless.mtu:                    auto
802-11-wireless.seen-bssids:            --
802-11-wireless.hidden:                 no
802-11-wireless.powersave:              0 (default)
802-11-wireless.wake-on-wlan:           0x1 (default)
802-11-wireless-security.key-mgmt:      wpa-psk
802-11-wireless-security.wep-tx-keyidx: 0
802-11-wireless-security.auth-alg:      open
802-11-wireless-security.proto:         --
802-11-wireless-security.pairwise:      --
802-11-wireless-security.group:         --
802-11-wireless-security.pmf:           1 (disable)
802-11-wireless-security.leap-username: --
802-11-wireless-security.wep-key0:      <hidden>
802-11-wireless-security.wep-key1:      <hidden>
802-11-wireless-security.wep-key2:      <hidden>
802-11-wireless-security.wep-key3:      <hidden>
802-11-wireless-security.wep-key-flags: 0 (none)
802-11-wireless-security.wep-key-type:  unknown
802-11-wireless-security.psk:           <hidden>
802-11-wireless-security.psk-flags:     0 (none)
802-11-wireless-security.leap-password: <hidden>
802-11-wireless-security.leap-password-flags:0 (none)
802-11-wireless-security.wps-method:    0 (default)
802-11-wireless-security.fils:          0 (default)
ipv4.method:                            auto
ipv4.dns:                               --
ipv4.dns-search:                        --
ipv4.dns-options:                       ""
ipv4.dns-priority:                      0
ipv4.addresses:                         --
ipv4.gateway:                           --
ipv4.routes:                            --
ipv4.route-metric:                      -1
ipv4.route-table:                       0 (unspec)
ipv4.ignore-auto-routes:                no
ipv4.ignore-auto-dns:                   no
ipv4.dhcp-client-id:                    --
ipv4.dhcp-timeout:                      0 (default)
ipv4.dhcp-send-hostname:                yes
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.never-default:                     no
ipv4.may-fail:                          yes
ipv4.dad-timeout:                       -1 (default)
ipv6.method:                            auto
ipv6.dns:                               --
ipv6.dns-search:                        --
ipv6.dns-options:                       ""
ipv6.dns-priority:                      0
ipv6.addresses:                         --
ipv6.gateway:                           --
ipv6.routes:                            --
ipv6.route-metric:                      -1
ipv6.route-table:                       0 (unspec)
ipv6.ignore-auto-routes:                no
ipv6.ignore-auto-dns:                   no
ipv6.never-default:                     no
ipv6.may-fail:                          yes
ipv6.ip6-privacy:                       -1 (unknown)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.dhcp-duid:                         --
ipv6.dhcp-send-hostname:                yes
ipv6.dhcp-hostname:                     --
ipv6.token:                             --
proxy.method:                           none
proxy.browser-only:                     no
proxy.pac-url:                          --
proxy.pac-script:                       --

I tried several things, including restart NetworkManager/wpa-supplicant, the router, and disabling PMF, but nothing worked.

Specifying --ask asks me for a password, but gives me the same error message afterwards. Removing and recreating the connection using nm-connection-editor didn't work either. It works without any problems on my Android device.

How can I connect to this Network?

5
  • My go-to one-liner for nmcli is nmcli dev wifi con <ssid> password <password>. I suspect it won't work in your case, but it might be worth trying. May 26, 2020 at 1:01
  • This one-liner just says "No network with SSID ... found". So it probably requires some configuration before.
    – ygoe
    May 31, 2020 at 10:33
  • is there any other device that can connect to this network?
    – binarysta
    Jun 16, 2020 at 15:15
  • @binarysta Yes there is including another Linux Laptop with the same operating system
    – msrd0
    Jun 16, 2020 at 15:26
  • Same issue here. Network is working fine for all other devices. (EDIT, one difference: debian based distro) Jul 8, 2020 at 9:59

2 Answers 2

3

It's a bit late but I found a potential workaround. According to the documentation of nmcli you can connect to your AP providing a passwd-file with the content of the file:

802-11-wireless-security.psk:secret12345

and the command:

nmcli con up <connection name> passwd-file <filename>

Hope, it helps.

0

For anyone else who comes across this issue, as I did recently after moving to a new ISP, this message is also caused by a mis-spelled password in nm-connection-editor. This was true for both Oracle Linux 7 and Oracle Linux 8.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .