1

On my Raspberry Pi which has been running for about 4 or 5 years now, I have a cron job running every hour that sets the time. I know form experience that my Pi has a tendency to drift its time quite a bit the longer it is running, so I found a script that resets it. It's been working perfectly for ages and suddenly it no longer works. The ntp.conf is here:

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift


# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
server 0.uk.pool.ntp.org iburst
server 1.uk.pool.ntp.org iburst
server 2.uk.pool.ntp.org iburst
server 3.uk.pool.ntp.org iburst


# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
#restrict 127.0.0.1
#restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust


# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
#broadcast 192.168.123.255

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient

The cron job I have runs this script:

#! /bin/bash
/etc/init.d/ntp stop
ntpd -q -g
/etc/init.d/ntp start

Now, when this runs the ntp -q -g command I get this set of messages and it never exits:

14 Nov 05:43:23 ntpd[1577]: ntpd 4.2.8p10@1.3728-o Sat Mar 10 18:03:33 UTC 2018(1): Starting
14 Nov 05:43:23 ntpd[1577]: Command line: ntpd -q -g
14 Nov 05:43:23 ntpd[1577]: proto: precision = 3.000 usec (-18)
restrict 0.0.0.0: KOD does nothing without LIMITED.
14 Nov 05:43:23 ntpd[1577]: restrict 0.0.0.0: KOD does nothing without LIMITED.
restrict ::: KOD does nothing without LIMITED.
14 Nov 05:43:23 ntpd[1577]: restrict ::: KOD does nothing without LIMITED.
14 Nov 05:43:23 ntpd[1577]: Listen and drop on 0 v6wildcard [::]:123
14 Nov 05:43:23 ntpd[1577]: Listen and drop on 1 v4wildcard 0.0.0.0:123
14 Nov 05:43:23 ntpd[1577]: Listen normally on 2 lo 127.0.0.1:123
14 Nov 05:43:23 ntpd[1577]: Listen normally on 3 eth0 192.168.0.42:123
14 Nov 05:43:23 ntpd[1577]: Listen normally on 4 lo [::1]:123
14 Nov 05:43:23 ntpd[1577]: Listen normally on 5 eth0 [2a02:c7f:9665:6900:ba27:ebff:fe24:90a5]:123
14 Nov 05:43:23 ntpd[1577]: Listen normally on 6 eth0 [fd57:5132:3318:0:ba27:ebff:fe24:90a5]:123
14 Nov 05:43:23 ntpd[1577]: Listen normally on 7 eth0 [fe80::ba27:ebff:fe24:90a5%2]:123
14 Nov 05:43:23 ntpd[1577]: Listening on routing socket on fd #24 for interfaceupdates

Any ideas? If I want the Pi clock to sync to a time server, what is the simplest way to do it?

  • 2
    Possible duplicate of NTP time sync takes a long time – Rui F Ribeiro Nov 16 '18 at 9:59
  • 1
    tinker panic as the first line in ntp.conf... see the URL above. – Rui F Ribeiro Nov 16 '18 at 10:00
  • The sync isn't taking a long time. It isn't happening. And I'm not sure what you mean by tinker panic. This has been working for about 4 years without a problem. I'm looking into another issue on the pi at the moment and that is name resolution and I think this is related because I don't think it can resolve the ntp server names. – snert Nov 17 '18 at 15:08
  • The easiest?: change from ntp to chrony. – Isaac Nov 17 '18 at 17:30
  • I'm puzzled that you feel the need to stop ntp, sync the clock, and restart ntp.  As long as ntp is running, your clock should be staying in sync.  What is your basis for saying that the Pi's clock is drifting?  Are you comparing it to something accurate and reliable, or are you comparing it to something like a wristwatch? If the Pi's clock is genuinely drifting while ntp is running, then there's something fundamentally wrong with your ntp setup. P.S. If you can't resolve the names of the NTP servers, that would qualify as a broken configuration. – G-Man Nov 18 '18 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.