3

Virtual machines are hypervised by vmware workstation.

I start my web server on vm1 - 192.168.0.31 running centos 7. I create and upload the kickstart file ks.cfg to 192.168.0.31/ks.cfg. You can look at the file below.

Every vm in my LAN can access the ks.cfg and read its content by going to 192.168.0.31/ks.cfg. I boot vm2 with netinstall iso of centos 7 and add ks=http://192.168.0.31/ks.cf to boot options and press enter. The only thing that comes to my mind is that somehow the mirror address in ks.cfg is not valid but i copied it from official centos site and tried multiple ones. I also tried mirrors found on the net, none of them solved the issue.

ks.cfg

#platform=x86, AMD64, or Intel EM64T
#version=DEVEL
# Install OS instead of upgrade
install
# Keyboard layouts
keyboard 'us'
# Use network installation
url --url="http://mirrors.mit.edu/centos/7/os/x86_64/"
# System language
lang en_US
# System authorization information
auth  --useshadow  --passalgo=sha512
# Use graphical install
graphical
# SELinux configuration
selinux --enforcing
# Do not configure the X Window System
skipx

# Firewall configuration
firewall --disabled
# Network information
network  --bootproto=dhcp --device=eth0
# Halt after installation
halt
# System timezone
timezone Africa/Abidjan
# System bootloader configuration
bootloader --location=mbr
# Clear the Master Boot Record
zerombr
# Partition clearing information
clearpart --all
5

The fault was kickstart file not including all necessary information for the automated installation to take place. The network is working fine. If the ks.cfg fails to get fetched the following message would appear:enter image description here If the ks.cfg gets fetched successfully but the contents are insufficient the following could greet us: enter image description here

To fix No disks selected define partitioning manually in GUI. Or use automatic partitioning (impossible in GUI, leaving everything blank won't result in automatic partitioning) - ks.cfg needs to be edited, just add autopart --type=lvm to the # System bootloader configuration section of the file. To fix Nothing selected in SOFTWARE SELECTION I just added the following:

%packages
%end

at the end of the file.

TL;DR:

After creating kickcstart file in GUI there will be need to supplement it with:

%packages
%end

If auto partitioning is wanted it can be done by supplementing the file with: autopart --type=lvm in # System bootloader configuration section. My mistake in that particular situation was leaving all partitioning options blank in GUI thinking it will result in automatic partitioning.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.