How can I install octave 4.2.0 or latest ? I have tried

https://askubuntu.com/questions/945517/installing-latest-version-of-gnu-octave-when-i-have-already-installed-other-vers does not give flathub command not found

https://stackoverflow.com/questions/41104551/installing-octave-4-2-0-from-source-on-ubuntu does not work

https://stackoverflow.com/questions/41104551/installing-octave-4-2-0-from-source-on-ubuntu does not work configure: error: BLAS and LAPACK libraries are required

https://stackoverflow.com/questions/41104551/installing-octave-4-2-0-from-source-on-ubuntu not work installed 4.0.3 instead

This is my PC version

e130167@instance-1:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.6 (stretch)
Release:        9.6
Codename:       stretch

I ran the command sudo -i to enter root then the following commands as instructed below. I am not sure if it is correct.

e130167@instance-1:~$ sudo -i
(base) root@instance-1:~# echo deb http://deb.debian.org/debian stretch-backports main > /etc/apt/sources.list.d/stretch-backports.list
(base) root@instance-1:~# apt update
Ign:1 http://deb.debian.org/debian stretch InRelease
Hit:2 http://security.debian.org stretch/updates InRelease
Hit:3 http://deb.debian.org/debian stretch-updates InRelease
Hit:4 http://deb.debian.org/debian stretch-backports InRelease
Hit:5 http://deb.debian.org/debian stretch Release
Hit:7 http://packages.cloud.google.com/apt cloud-sdk-stretch InRelease
Hit:8 https://download.docker.com/linux/debian stretch InRelease
Hit:9 https://nvidia.github.io/libnvidia-container/debian9/amd64  InRelease
Hit:10 http://packages.cloud.google.com/apt google-compute-engine-stretch-stable InRelease
Hit:11 https://nvidia.github.io/nvidia-container-runtime/debian9/amd64  InRelease
Hit:12 http://packages.cloud.google.com/apt google-cloud-packages-archive-keyring-stretch InRelease
Hit:6 https://packages.cloud.google.com/apt kubernetes-xenial InRelease
Ign:13 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu disco InRelease
Hit:14 https://nvidia.github.io/nvidia-docker/debian9/amd64  InRelease
Ign:16 http://ppa.launchpad.net/octave/stable/ubuntu disco InRelease
Ign:17 http://ppa.launchpad.net/picaso/octave/ubuntu disco InRelease
Err:18 http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu disco Release
  404  Not Found
Err:19 http://ppa.launchpad.net/octave/stable/ubuntu disco Release
  404  Not Found
Err:20 http://ppa.launchpad.net/picaso/octave/ubuntu disco Release
  404  Not Found
Reading package lists... Done
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
E: The repository 'http://ppa.launchpad.net/alexlarsson/flatpak/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/octave/stable/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/picaso/octave/ubuntu disco Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target Translations (main/i18n/Translation-en_US) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list.d/backports.list:1 and /etc/apt/sources.list.d/stretch-backports.list:1
  • Please explain why the installation failed. You need to give us more information about your problem. Share the logs of installation. – JonLord Nov 15 at 16:25
  • sudo apt-add-repository ppa:octave/stable sudo apt-get update sudo apt-get install octave installs 4.0.2 instead of the latest one – Kong Nov 15 at 16:33
  • You repeated the same link three times, is that what you intended? – Stephen Kitt Nov 15 at 16:36
  • Note that those PPAs are for Ubuntu. Ubuntu and Debian are different enough that using them on Debian may cause problems. Just a heads-up. – marcelm Nov 15 at 20:16
up vote 7 down vote accepted

You can install Octave 4.4.1 (as of this writing) from Stretch backports:

  1. add the backports repository (as root)

    echo deb http://deb.debian.org/debian stretch-backports main > /etc/apt/sources.list.d/stretch-backports.list
    
  2. update your package indexes

    apt update
    
  3. install OpenJDK

    apt install -t stretch-backports octave
    

If you’d rather use sudo, the equivalent steps are

echo deb http://deb.debian.org/debian stretch-backports main | sudo tee /etc/apt/sources.list.d/stretch-backports.list
sudo apt update
sudo apt install -t stretch-backports octave

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.