19

I am using Manjaro OS (Arch Linux based distro) on my HP Notebook 15 with Pentium IV processor.

I have tried changing timezones using "Orange Globaltime" built into the distro but despite being connected to the internet, the time is not updated.

Furthermore, I have used $sudo date +%T -s "14:26:00" to set the time of my laptop. But after I login in again, the time is back to being wrong again.

How can I fix my laptop's time?

4
  • 1
    What does the date command show exactly, how much is it wrong, and in what time zone are you located?
    – Kusalananda
    Nov 15, 2018 at 15:53
  • What does the date command show exactly? Its output usually includes a timezone.
    – Kusalananda
    Nov 15, 2018 at 16:00
  • It's fixed. NTP wasn't installed.
    – user306655
    Nov 15, 2018 at 16:02
  • Manjaro moves quickly but just for people seeing this in 2023 and seeing this behaviour on the latest Manjaro Desktop, I activate the checkboxes for "Set time and date automatically" and the "Hardware clock in local timezone" located in the Time and Date Dialogue Window of the manjaro Settings Manager. Mar 14, 2023 at 14:22

1 Answer 1

33

It seems as though Network time Protocol is either not installed or not working on your laptop. I suggest using the following commands to install it:

Step 1: Install NTP

sudo pacman -S ntp

Step 2: Turn on NTP

sudo timedatectl set-ntp true

Source: https://wiki.manjaro.org/index.php?title=System_Time_Setting

2
  • 1
    This works. Just restarted my laptop without internet. The time is correct :)
    – user306655
    Nov 15, 2018 at 16:02
  • 2
    This is probably a bug, I had the same problem when I've installed multiple times. Sep 6, 2020 at 6:41

You must log in to answer this question.