0

I want to customize a Ubuntu Desktop Iso and I have come that far, that I am in the chroot environment.

The problem is that I do not have Internet access in there to install anything.

I just can ping 8.8.8.8, but not www.google.com (for example). Everything goes through a proxy tho, so I made a file apt.conf in the apt folder of the chroot environment but still nothing happens.

I can not run lines like: sudo apt-get update -> It just says "W: Failed to Fetch over and over again"

Does somebody know a solution? I followed these steps (to the part with the sed commands)

3

You have internet connection, as evidenced by the ping to 8.8.8.8. You just don't have DNS name resolution.

See the file /etc/resolv.conf in your root file system and copy it to the chroot environment.

  • Thank you for your help, I already tried this sudo cp -a /etc/resolv.conf ~/remastering/newfilesystem/etc/ – kcdk Nov 15 '18 at 6:59
  • I also tried using a simple network without any proxys instead. Still no connection to apt commands – kcdk Nov 15 '18 at 7:00
  • In the chroot, try nslookup, host, dig or any program of your choice to verify that DNS resolution works. – RalfFriedl Nov 15 '18 at 7:02
  • Thanks, I did the asked commands but it says on both (nslookup host and dig): ;; connection timed out; no servers could be reached than I tried ping 8.8.8.8 for fun again and this worked with 10,2ms responsetime So weird!# – kcdk Nov 15 '18 at 7:30
  • 2
    I copied the root resolv.conf in my home folder and copied it than into the chroot environment. NOW pinging www.google.com AND apt commands work! THANK U! – kcdk Nov 15 '18 at 8:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.