-1

This is the screen shot of my gnome-terminal:enter image description here

You can see that all the text is messed up. The username is heman and the host name is arch linux but the characters are not even readable because they are sticked to each other how can I fix this problem. How can I increase the letter spacing

  • Is it only your prompt that is affected? What about commands you issue and the other text that appears? – DK Bose Nov 14 '18 at 16:04
  • Install a monospace font. – jasonwryan Nov 14 '18 at 16:45
0

The font you use in your terminal is not a monospaced font or the configuration file of the terminal has a font size your font doesn't accept.

Probably it's located in /etc/vconsole.conf: https://wiki.archlinux.org/index.php/Linux_console#Fonts

Preview and temporary changes Tip: An organized library of images for previewing is available: Linux console fonts screenshots. $ showconsolefont shows a table of glyphs or letters of a font.

setfont temporarily change the font if passed a font name (in /usr/share/kbd/consolefonts/) such as

$ setfont lat2-16 -m 8859-2 So to have a small 8x8 font, with that font installed like seen below, use e.g.:

$ setfont -h8 /usr/share/kbd/consolefonts/drdos8x8.psfu.gz Font names are case-sensitive. With no parameter, setfont returns the console to the default font.

Tip: All font changing commands can be typed in "blind". Note: setfont only works on the console currently being used. Any other consoles, active or inactive, remain unaffected.

  • OP is working in Wayland/X, not the console, so setfont is irrelevant. – jasonwryan Nov 14 '18 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.