2

I'm followng Oracles instructions on how to create and manage a vm through VB's CLI.

when I run

VBoxManage createvm --name Debian_64 --ostype Debian_64 --register

I get the following error

VBoxManage: error: Could not create a directory '/Users/cbeltrao/VirtualBox VMs/Debian_64' to save the settings file (VERR_FILE_NOT_FOUND)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine, callee nsISupports
VBoxManage: error: Context: "SaveSettings()" at line 276 of file VBoxManageMisc.cpp

1 Answer 1

2

FIX: My VirtualBox VMs folder was a symlink. I am not sure wether it was a broken link or if the virtualbox just couldnt handle the fact that the fodler was a symlink. But I deleted theVirtualBox VMs folder, created a new folder an now it works.

3
  • 2
    Thanks for coming back and adding your solution when you figured it out. Nov 13, 2018 at 14:55
  • macOS symbolic link files will not be understood by most unix tools, no
    – thrig
    Nov 19, 2018 at 15:06
  • It was actually a broken symlink, it works fine now!
    – koperandus
    Nov 19, 2018 at 18:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .