-1

I created a network repository for the hosts that hasn't got internet connection.So the environment has 1 repo server and 1 client. (It's in the test stage so both host can go to internet). I did make a filesystem and mount it on the path /AllRepositories/Centos7. Than I tried to download the rpm packages to here. I also did the requirement steps createrepo / createrepo --update. The problem is, the client host can't install packages from this host.

Server config

createrepo /var/www/html/AllRepositories/Centos7

I download all packages with this command;

repoquery -a | xargs repotrack -a x86_64 -p .

I update db with;

createrepo --update /var/www/html/AllRepositories/Centos7

My client's .repo config is

[RemoteRepoDisk]
name=Remote Repository Disk
baseurl=http://<ip address>/AllRepositories/Centos7/
enabled=1
gpgcheck=0

So, when I try to download from client, I first type "yum repolist all" and my client see that repository is enabled and there are 9911 packets available. Than, when I type, "yum install nano" for example, it brings the packet download page.

Total download size: 440 k
Installed size: 1.6 M
Is this ok [y/d/N]:

When I type y, it says that

Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
nano-2.3.1-10.el7.x86_64.rpm   FAILED
http://<<ip address>>/AllRepositories/Centos7/nano-2.3.1-10.el7.x86_64.rpm: [Errno 14] HTTP Error 403 - Forbidden0 B  --:--:-- ETA
Trying other mirror.


Error downloading packages:
  nano-2.3.1-10.el7.x86_64: [Errno 256] No more mirrors to try.

But from server, when I try to download the rpm packages to a normal directory(not mounted path), my client can see and download the packets.How can I download packets from clients from the mounted path?

UPDATE:

In error logs of httpd:

(13)Permission denied: [client 10.0.6.180:52939] AH00035: access to /AllRepositories/centos7/nano-2.3.1-10.el7.x86_64.rpm denied (filesystem path '/var/www/html/AllRepositories/centos7/nano-2.3.1-10.el7.x86_64.rpm') because search permissions are missing on a component of the path

It says that my search permissions are missing. I did some research for error 13. It indicates a filesystem permission problem. So I give chmod 755 to the directory /var/www/html and restart httpd but still it gives the same error.


  • SELinux may be interfering with your RPM files: serverfault.com/questions/697752/… – Haxiel Nov 13 '18 at 7:56
  • 1
    Your web server prevents from downloading rpm packages from repository for permission issues. – minish Nov 13 '18 at 7:57
  • @mimish yes it gives permission error. So I gave 755 to the /var/www/html directory but still it gives the same error. – G.Baysec Nov 13 '18 at 12:12
0

I turned off selinux after giving the permissions to directories with setenforce 0 and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.