1

My OS is: CentOS Linux release 7.5.1804 (Core) This problem appeared after a linux update some time last month (i don't know when). Before that, everything was working fine.

I have a folder on my linux system that uses arround 20Gb of disk space. On that system, i create users and assign to them a quota of 10Gb. Then, i create symlinks on the user's home to all files and folders of the above folder that contains 20Gb of files. Usually, the user is left with arround 9,8-9,9Gb of free space. But, after the update, when i check the user's quota, he doesn't have free space and is even using -10Gb. Wich means that he can't run the software that is being linked because lack of free space.

Can someone point me to a way to fix this out?

Edit: These are an example of the commands I run:

# adduser testuser1
# edquota testuser1                 # and type 20971520 under hard
# mkdir /home/testuser1/folder1
# mkdir /home/testuser1/folder2
# mkdir /home/testuser1/folder3
# ln -sf "/home/program/bigfile1" "/home/testuser1/bigfile1"`
# ln -sf "/home/program/folder1/bigfile2" "/home/testuser1/folder1/bigfile2"
# ln -sf "/home/program/folder2/bigfile3" "/home/testuser1/folder2/bigfile3"
# ln -sf "/home/program/folder3/bigfile4" "/home/testuser1/folder3/bigfile4"
# cd /home/testuser1
# du -sh      # Gives this:
15k

closed as unclear what you're asking by Rui F Ribeiro, Jeff Schaller, schily, thrig, RalfFriedl Nov 12 '18 at 17:41

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • uh, we'll need a lot more detail... have you tried using du or find to see what all files are owned by the user and how much space they occupy? – thrig Nov 12 '18 at 17:34
  • Continuation: # quota -u testuser1 show me that the user has 10G of quota and is using 18.5G – Webix Nov 13 '18 at 7:56
  • quota displays the quota. how are you actually editing the quota? Also edit your question instead of putting the text in comments. – thrig Nov 13 '18 at 14:50
  • i use the edquota and put 20971520 (10Gb) under hard – Webix Nov 13 '18 at 15:43

Browse other questions tagged or ask your own question.