0

I see that one of the users has a 100% cpu process named tracker-extract. I tried to terminate that based on the suggestion here, however, still I see that it is running. All users have such process but as you can see one of them consumes a lot of cpu.

# tracker daemon -t
Found 1 PID…
  Terminated process 2265 - 'tracker-server'
# ps aux | grep tracker-extract
jafarian 21478  0.0  0.0 728000 11664 ?        SNl  Oct29   0:00 /usr/libexec/tracker-extract
jafaria+ 23002 98.3  0.0 810900 18252 ?        RNl  Nov09 3746:02 /usr/libexec/tracker-extract
jafaria+ 31826  0.0  0.0 917128 21684 ?        SNl  Oct31   3:21 /usr/libexec/tracker-extract

Just killing the PID isn't a solution because it runs again. How to fix that?

  • Did you run the command in suggestion as root? – Romeo Ninov Nov 12 '18 at 7:28
2

You should install tracker-ui-tools via yumfor older versions. For newer version install tracker-preferences directly.

Then use tracker-preferences to switch on/off what you want/don't want.

For more information check this link and this link.

  • There is no such package. Is it fine to just install tracker-preferences? – mahmood Nov 12 '18 at 7:48
  • yes, actually tracker-ui-tools is for older versions. – Prvt_Yadav Nov 12 '18 at 7:50
  • OK I installed that and then logged in as that user and ran tracker-preferences and unchecked the options. Still I see that a process for that user consumes 100% cpu. – mahmood Nov 12 '18 at 8:10
  • 1
    Try to check after logout or restart. Is this one of the process which you check out?? – Prvt_Yadav Nov 12 '18 at 8:14
-1

Centos 7

Please note:

Install tracker-preferences as root yum install tracker-preferences

Run tracker-preferences as normal user Set everything off (or leave whatever you think you need).

Reboot

System is nice again after that :))

  • And then it came back again. Just when I posted my comment tracker-extract came back to live consuming 100% CPU. All I can think off is running tracker daemon -t after each boot. As a normal user. That seems to kill it. – Johan Jan 25 at 8:49
  • And then it came back again. – Johan Jan 25 at 8:49
  • I forgot to uncheck Enable for initial data population in tracker-preferences. It is ok now. Gone. I think. Because I saw tracker-extract pop up and die just now. k for me, I can always use tracker daemon -t if necessary. (For less experienced users something like this is enough to take the PC to a repair shop). – Johan Jan 25 at 9:11
  • And now tracker-extract is back in full force, 100% CPU. – Johan Jan 25 at 9:12
  • Last comment. I let the PC run for 2 days straight before and tracker-extract was still running. To me that looks abnormal. I have a lot of files but not that many. Also maybe an idea to use nice for tracker-extract so it does not stop you from using the system. Case closed. – Johan Jan 25 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.