2

I am running qemu on Windows on a 64-bit computer. I am trying to run Linux mint iso with Qemu in powershell. This is my command to run it in powershell.

qemu-system-x86_64 -boot d -cdrom E:\linuxmint-19.iso -m 512 -hda LinuxM19.img, -drive format=raw,file=E:\Data.vhd

I am booting the iso from a USB and the LinuxM19.img is saved in the folder where all the Qemu stuff is. I made that file using Qemu.

My problem is when i select start Linux it takes a few seconds to load then it shows a black screen with this error message in powershell.

WARNING: Image format was not specified for 'LinuxM19.img' and probing guessed raw.
         Automatically detecting the format is dangerous for raw images, write operations on block 0 will be restricted.
         Specify the 'raw' format explicitly to remove the restrictions.

Then it goes to the selection menu where i can select to install it or run it i enter the run mode and i get a blank window and in powershell it says:

(qemu-system-x86_64.exe:20488): Gtk-WARNING **: Could not load a pixbuf from /org/gtk/libgtk/theme/Adwaita/assets/check-symbolic.svg
This may indicate that pixbuf loaders or the mime database could not be found.

I am using powershell since cmd is blocked on my account.

closed as off-topic by Rui F Ribeiro, Thomas, RalfFriedl, mosvy, Archemar Nov 12 '18 at 8:18

  • This question does not appear to be about Unix or Linux within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • The OS you're trying to run requires at least 1 GiB of memory, and QEMU is going to be slow on Windows without the experimental HAXM support. The command in your question says the VM is getting 0.5 GiB of memory, so check if that's the issue by doubling or quadrupling the amount. – dsstorefile1 Nov 11 '18 at 12:56
  • how would i manage to make the amount more – Dextron Nov 11 '18 at 20:35
  • I did this to create the img file .\qemu-img create LinuxM19.img 2G so i dont think that is the problem – Dextron Nov 11 '18 at 20:40
  • I got linux to boot then it took me to the linux mint loading menu. It took a while to load i got a I/O error then the screen glitched and a grey linux mint logo appeared everywhere then my computer started to automatically resize the window – Dextron Nov 11 '18 at 21:58
  • 1
    @Dextron by changing its -m option from 512, eg. -m 4G – mosvy Nov 11 '18 at 22:17

Browse other questions tagged or ask your own question.