0

I have Linux Mint 19 64-bit Cinnamon.

I have just installed wireshark-gtk with:

sudo apt-get install wireshark-gtk

while installing I was asked this:

wireshark non-root question

Answering Yes as you can see, as I am the sole user of this laptop, and I don't see much of the security issue anyways enabling this. But I have a different question than this.


How come that when I run Wireshark from the root terminal, I can listen on my Ethernet, and when I run Wireshark as non-root, interfaces are not even listed there?

2

The problem is the installer does not create the group for itself, do it manually with:

$ sudo addgroup --system wireshark

and add yourself to the group with:

$ sudo adduser $USER wireshark

I have then reconfigured the wireshark-common with:

$ sudo dpkg-reconfigure wireshark-common

answering intentionally No first

and finally:

$ sudo dpkg-reconfigure wireshark-common

answering intentionally Yes afterwards.

I have also logged out / in back. This is necessary.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.