0

Using PHP and TCPDF I create A3 portrait PDF document that I need to split in two A4 lanscape. So the top of the A3 must became page 1 of the A4 and the bottom of the A3 must became page 2.

As PHP+TCPDF seems not able to do that, I have installed pdfposter (6.0) and exec it from PHP. It works as the A4 page is created, but not the way I want.

I tried "pdfposter -m a4 -p 2x1a4" and "pdfposter -m a4 -p 1x2a4" but each time I get the result of the picture enclosed: left part is my A3 and right, the result I get which is not "really" what I'm waiting for...

I though my A3 was not corret but when I use online tools like the one at sejda.com I can split the A3 on two A4.

Any idea about the pdfposter command or maybe another tool? (I'm on Debian Jessie).

Edit: I tried also "pdfposter -s1" and get same wrong result...

enter image description here

2
  • (1) What do you mean by “my A3 was not correct”? (2) Wow, that result that you’re getting isn’t even close to what you want — or am I totally missing the point? (3) Are you saying that you can get the result you want from online tools like the one at sejda.com? (4) People seem to like the PDF Toolkit, PDFtk.  I’ve never used it, so I don’t know whether it will help you; you might want to check it out. Nov 10, 2018 at 21:03
  • (1) I thought it was not. As it's a PDF I create on the fly. But i fact all software I've used are able to rad it without any problem. (2) You're right. Lol. (3) Yes. Using sedja.com I have exactly the result I want. (4). I'll have a look. Thanks!
    – Peter
    Nov 10, 2018 at 21:13

1 Answer 1

0

Finally, I found! pdfposter you get when you just apt-get on Debian, is the stable version, 0.6 This version works perfectly with basic PDF. But in my case, the PDF is made using the rotation feature of PHP/TCPDF (the top bloc is rotated by 180° and the middle one by 90°). This IS the problem and the PDF I get is not compatible with pdfposter 0.6

To get better compatibility you need to install the last version from Git (pdfposter 0.7). And with this version, it works fine!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .