3

I am using Debian Sid/unstable.

After a rather large set of installation (changing desktop from cinnamon to gnome) I got a completely non-functional clipboard.

I literally cannot copy/paste in any way; even "middle button pasting" is not working.

Another symptom: in gnome-terminal selection vanishes in a very short time (<1s.).

What should I check?

Update: switching to a brand-new user and reinstalling in-place (apt install --reinstall <all packages>) did not change anything.

Update2: I found the culprit: clipit which is auto-installed as dependency by lxde. I have it running at startup and killing it "cures" the problem. Any advice (beside the obvious: "uninstall it") would be welcome.

0

If you want the more general advice, it is that installing the meta-package for more than one desktop environment can have pretty weird effects, and you get to clean up the mess :-P. There are some good reasons why Ubuntu and Fedora have flavours/spins i.e. different OS install disks for different desktop environments.

Of course if you find a nice clean solution, or the weird effect you find is dangerous enough, you can also report a bug and hope that Debian will solve the conflict.

The doc for clipit --daemon (which is autostarted) says it is used "to keep your clipboard and primary contents safe." There's several things you might guess this means. However, I expect at least one of the problems it solves, is the problem that the X clipboard for copy/paste is effectively lost when you close the app you copied from. Perhaps Debian LXDE expects that you would like something to preserve the clipboard contents on LXDE.

The GNOME desktop provides this feature already. I would advise not running clipit --daemon or equivalent in a GNOME session, in case they conflict. Maybe you found such a conflict. (Although, you don't explicitly say if you have the same problem in LXDE as well?)

(At least, I think GNOME provides a clipboard manager which works for X Windows. Some details are mentioned in this old Ubuntu document. There seems to an issue that this does not work when you use native Wayland apps and GNOME with Wayland).

The problem is that clipit is not part of LXDE specifically. It seems plausible you might install it because you want to use it in an environment which is not LXDE, but also supports autostart. (?) This might justify clipit.deb providing /etc/xdg/autostart/clipit.desktop or something like that, to autostart clipit in any desktop environment. Or maybe the packager felt the alternatives were awkward, i.e. creating a stub package lxde-clipit-autostart, or putting an LXDE-specific autostart inside the non-LXDE specific clipit package.

Some autostart .desktop files include a line like NotShowIn=GNOME;Unity;. Or they can use a line OnlyShowIn=. If they don't have a specific line like that, the autostart will be started in all desktop environments which support autostart.

You could test adding NotShowIn=GNOME to clipit.desktop. If it works, you could propose this solution for clipit.deb, in a bug report. I don't think this is a fully general solution. A different lightweight desktop could pull in a different generic clipboard manager autostart. So it might be debatable whether this, or any other solution, could be accepted as a change to clipit.deb.

  • Thanks for the lengthy explanation. I still fail to understand why all Display Managers have settings enabling user to chose between several "Desktops". Is all that supposed to work? – ZioByte Nov 12 '18 at 18:51
  • @ZioByte definitely supposed to work between Gnome Classic, Gnome on Xorg, and Gnome on Wayland :-). I might be exaggerating slightly. .desktop files definitely have hacks like this to make it work better. But when I look at this example, it feels like it's likely for some problems to happen, and need careful thinking about how to solve them when they're noticed. Debian has a reputation for having more possible combinations than it can realistically provide quality assurance on. – sourcejedi Nov 12 '18 at 19:18
0

I am not sure if this is your problem, but there are strange rules to middle click copy and paste, these are my findings from years of using linux. Observe the following rules:

1) Select your text.

2) Do not close down the window, your text will sometimes be lost.

3) Do not type anything (including keystrokes to change windows) else your text may be lost.

4) Move the window to the same workspace as the window you are pasting to and copy it in the same workspace.

5) Sometimes minimising windows loses the copy text.

6) Middle click into the window where the data should go.

7) If you can use right click -> copy / right click -> paste use it instead, it's more reliable.

Despite all these rules, sometimes copy and paste just works (tm). It's a dark art, and it seems for 10 minutes at the time, copy and pasting from terminal just refuses to work at all, or pastes some random garbage from 2 hours ago. If you've got any tips, please paste them here. Together we can figure this out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.