0

I got a blank screen after the "Welcome to GRUB" greetings.

I ran grub-install and grub-mkconfig from a chroot, but still couldn't get to the GRUB menu.

Because of the setup (former dual boot with another GNU/Linux distribution) I thought maybe it was using GRUB-legacy, so I ran both this first method, which confirmed that GRUB-legacy was not installed, and this second method, which confirmed GRUB2 was installed. However, confusingly this third method seemed to provide evidence that GRUB-legacy was installed.

Consequently, I decided to wipe the MBR and reinstall a fresh GRUB2 on it. As suggested elsewhere, I used dd if=/dev/zero of=/dev/hda bs=1 count=446 to wipe the MBR (above commands and a reboot all confirmed the success of this command).

Finally, I chrooted again into my working partition and ran grub-install, which reported "Installation finished" without errors but didn't seem to actually modify the MBR.

Now I'm lost, how am I supposed to install GRUB2 on the MBR ?

FWIW, /boot is on /dev/sda3, which is set as "bootable".

For now I ended up installing LILO (I'm running Slackware) but I'm still willing to fix this issue.

Update :

I couldn't help but run grub-install again after booting through LILO. This time the MBR was successfully modified according to the second method mentioned above (though the third method still showed LILO but I guess it's only a remaining useless string) and the fact that I got the GRUB greetings.

I suppose I'm missing some binding besides /sys and /proc when running grub-install through chroot (yes I tried again), but which one(s) ? It says "No error reported"…

(Still get the blank screen, though… Gonna stick to LILO for now.)

  • The “Welcome to GRUB” message indicates to me that it’s installed in MBR. However, it doesn’t sound like partitions with OS’s were detected. Do your grub configuration files contain anything related to your OS partitions? – Peschke Nov 10 '18 at 9:05
  • @Peschke The greetings only appears when I run grub-install from the complete installation. It does not appear when I run it from the chroot. I'll edit the title to make it clear. – Skippy le Grand Gourou Nov 10 '18 at 9:22
  • 1
    I think you should add to your question: the list of your drives (hda? sda?), which one your system boots from, the list of partitions on them and the actual grub-install and grub-mkconfig you ran, with all the arguments. – fra-san Nov 10 '18 at 9:41
  • @SkippyleGrandGourou help.ubuntu.com/community/… – somethingSomething Nov 10 '18 at 12:58
  • 1
    Nevermind, I don't have time to dig this issue currently so I'll stick to LILO. @somethingSomething Thanks, it seems that the second link has a number of different options which I may give a try. – Skippy le Grand Gourou Nov 11 '18 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.