2

All these test activity I am carrying out on my AWS instance for my test purposes.

I am trying to install XRDP for Remote access on SUSE Linux Enterprise Server 12 SP3 (HVM), SSD Volume Type on AWS & stuck up. Actually I am trying to configure XRDP on the AWS Linux instance.

I followed this tutorial but no success : https://www.suse.com/documentation/s...igure_rdp.html'

Previously : All these options were pretty simple & straight forward on SUSE Linux Enterprise Server 11 SP4 (HVM), SSD Volume Type. Can anybody please through some light on this !! how to configure Linux instance so that I can continue with the installation of SAP B1 9.3.

Current Issue : Getting the logging screen & after entering the credentails then everything is blank, I cannot do anything on the screen. No UI nothing, Even I tried setting the display to 16-bit or 24-bit only but no success.

So let me know your thoughts or suggest some document which explains how to configure Linux 12 for XRDP.

1
  • This assumes you already have X on your server, but check out this answer
    – jc__
    Nov 8, 2018 at 20:04

3 Answers 3

2

My issue has been solved !!!

Below are the steps I performed & it will be helpful for them who stumble upon the same issue.

# zypper update ( to update SUSE Linux Ent. Server)
# zypper install -t pattern gnome-basic
# zypper install xrdp

Enable VNC Remote Login

# Open yast, Select "Network Services", Select first entry "Remote Administration with VNC"
# Enable service

Configure Window Manager to use Gnome Edit file /etc/sysconfig/windowmanager Change entry DEFAULT_WM="" to DEFAULT_WM="gnome".

Startup the RDP service and make it start automatically after Reboot

# service xrdp start
# chkconfig --set xrdp on
# systemctl start xrdp
# systemctl enable xrdp

Above are the steps which I performed to get the activate & use RDP session through my windows, If in-case anybody have any question let me know I will be happy to assist you.

Regards,

Rahul Jain

1
  • It should not necessary be Gnome, it can be KDE as well, for example
    – Andriy F.
    Dec 15, 2023 at 16:25
1

Following is steps for achieve this on SLES SP1 (Tested on 28Feb2023)

  1. Update the package manager by running the following command:

    sudo zypper update
    
  2. Install the GNOME desktop environment and the XRDP package by running the following command:

    sudo zypper install patterns-gnome-gnome_basic xrdp
    
  3. Once the installation is complete, start the XRDP service by running the following command:

    sudo systemctl start xrdp
    
  4. Enable the XRDP service to start automatically on system boot by running the following command:

    sudo systemctl enable xrdp
    
  5. Configure the firewall to allow incoming connections to the XRDP service by running the following command:

    sudo firewall-cmd --add-port=3389/tcp --permanent
    sudo firewall-cmd --reload
    
  6. Connect to the SLES server using a Remote Desktop Client, such as Microsoft Remote Desktop or Remmina, and enter the IP address of the server.

  7. Enter your username and password to log in to the GNOME desktop environment.

1
  • It should not necessary be Gnome, it can be KDE as well, for example
    – Andriy F.
    Dec 15, 2023 at 16:25
0

I would like to add an extra answer that references the others but adds the following important information (especially useful for virtual machine users!): make sure you disable autologin.

I spent several hours trying to figure out why my RDP connection was just showing me a black screen and the X cursor. Due to an activated automatic login, whenever my VM was restarted, it would automatically "log into itself". This automatically blocks an RDP connection.

I discovered this by running pkill -u <username_who_runs_session> -SIGKILL through my virtual machine manager (I have KVM/QEMU with libvirt and the default graphical virtual manager), which lead to the RDP connection from my remote system getting a green light and me being able to log into the VM remotely. After searching online, I discovered that the automatic login has to be disabled, which I usually turn automatically on especially for VMs, since they don't have anything of value inside.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .