1

I unmounted a Windows drive in Linux in order to remount it so I would have read/write access to the Windows files. I can no longer boot into Windows but still have access to the files. Is there a way to fix this?

The command I issued to mount the Windows partition read/write-enabled was

mount -o rw,mount,rw -t ntfs /dev/sda4 /mnt/ntfs/ 
3
  • What exactly did you do? Commands please.
    – roaima
    Nov 7, 2018 at 19:42
  • 1
    The command mount -o rw,mount,rw -t ntfs /dev/sda4 /mnt/ntfs does not remount your partition, and it has two "rw" flags. I think you meant mount -o remount,rw -t ntfs /dev/sda4 /mnt/ntfs. What errors are you getting when you try to boot Windows? Nov 8, 2018 at 11:27
  • Anyway filesystem type ntfs is a pure linux kernel implementation which lacks features (and increases the chances of corrupting something when used read/write). You should be using ntfs-3g which is a fuse implementation, that while lacking pure kernel's speed, would have more features. Its manpage also gives a warning about windows' hibernation
    – A.B
    Nov 8, 2018 at 13:30

1 Answer 1

0

Try to use windows cd/usb key and run "Repair my system".

Generally, if You want to use dual boot, and read windows partition, you should disable so called "Fast boot" feature in Windows. It is nicely explained here:

https://askubuntu.com/questions/452071/why-disable-fast-boot-on-windows-8-when-having-dual-booting

Not the answer you're looking for? Browse other questions tagged or ask your own question.