27

I've somehow managed to remove the toolbar and menu-bar from Okular. After I've found no way to reactivate them from "outside" – sice I can't click on Options anymore – I've tried to reinstall a clean version after removing it with apt-get remove --purge okular. However, it didn't work, the tool- and menu-bars were still unavailable. I also looked for any configuration files in the home directory, without success. How should I proceed now in order to restore a clean Okular.

1
  • 2021 ... menu 'gone' (still?) My RC file says: MenuBar=Disabled. Wild???!
    – will
    Oct 15, 2021 at 14:00

4 Answers 4

42

The keyboard shortcut to show/hide the menu bar is Ctrl-m. I found the config file where the setting is stored at ~/.config/okularrc.

1
  • 1
    thank you for the keybinding -- at the time I've seached for it. Regarding the config file. It should be mentioned that then, as far I'm remembering right, it has not affected the setting, even if it was deleted.
    – alex
    Feb 11, 2021 at 10:13
6

So you have to open Okular without any document and right-click on the background surface of where the document is normally shown (for me grey). If -- and only if -- the toolbars are not visible you will provided with a context menu with the option to show the bars.

1
  • 1
    Thank you! Alternatively, just hit CTRL+M
    – Prof.Chaos
    Feb 6, 2021 at 0:56
0

You can find the config files in ~/.var/app/org.kde.okular You can remove it manually or by entering this in your terminal

rm -R ~/.var/app/org.kde.okular
1
  • 1
    @matemethieu: Thank you very much. For Debian 9 it is in ~/.kde/share/apps. However it doesen't work. Found a solution. See below.
    – alex
    May 16, 2019 at 21:07
0

For my Ubuntu 18.04, right-clicking on the content space of Okular without a document showed the option to turn on showing the menu bar

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .