5

My laptop (Kubuntu 18.04) has only a single sound card. I want to take input from the Mic of the headphone I connect but get the output to the built-in speaker of the laptop.

I can toggle input (between internal and headphone mic) when headphone is connected, but if try to toggle output to speaker in the Pulseaudio Volume Control settings it shows "Unavailable" and if I switch to it, no sound comes out (i.e. the speaker works iff headphone is disconnected).

I tried with Simultaneous Output but no luck.

2
  • Try jack audio Nov 7, 2018 at 17:42
  • I have already installed jack but it does not show built-in speaker and headphone as separate clients rather it shows a single client named "system".
    – Chitholian
    Nov 8, 2018 at 4:41

2 Answers 2

0

What worked for me was disabling "Auto-Mute Mode" from ALSA Mixer (see https://superuser.com/questions/431079/how-to-disable-auto-mute-mode).

Laptop speakers will still appear as "unavailable", but if you select them after you plugged in your headphone jack, you should hear the audio playing from your laptop.

0

Try pavucontrol.

It only work with pulseaudio, but it should work for your use-case. (it's pretty intuitive too as far as I'm aware)

It's also on most distro's repository.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .