1

What I wanted to do: Play MotoGP2015...

What I tried to do: I installed the game by using an ISO FIle and using PlayOnLinux for the .exe.

The PleyOnLinus crash problem: I double click on the launch icon but POL crashes without providing any valuable information for fixing the problem.

Game requirements:

  • MINIMUM: OS: Windows Vista SP2 / Windows 7 SP1 / Windows 8 / Windows 8.1
  • Processor: Intel Core i3-530 @ 2.93 GHz / AMD Phenom II X4 850 @ 3.30 GHz
  • Memory: 4 GB RAM
  • Graphics: NVIDIA GeForce GTX 460 @ 1GB / ATI Radeon HD 6790 @ 1GB* * DirectX: Version 10 Hard Drive: 30 GB available space
  • Sound Card:
  • DirectX compatible Additional Notes:
    • Laptop versions of graphics cards may work but are not officially supported.

Recommended:

  • OS: Windows 7 SP1 64-Bit / Windows 8 64-Bit / Windows 8.1 64-Bit
  • Processor: Intel Core i7-3770 @ 3.4 GHz / AMD FX-8350 @ 4.0 GHz
  • Graphics: NVIDIA GeForce GTX 780 / AMD Radeon R9 290X
  • DirectX: Version 11
  • Additional Notes: *Laptop versions of graphics cards may work but are not officially supported.

My OS:

  • NAME="Linux Mint" VERSION="19 (Tara)" 4
  • Language : Spanish

MY LAPTOP: * HP 250 G6 Notebook PC * Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz Core Count: 2 Core Enabled: 2 Thread Count: 4 64-bit capable Multi-Core * Intel Corporation HD Graphics 620

What happened step by step:

  1. I downloaded the MotoGp2015 ISO FILE on skidrowcodex.com /motogp-15-pc-codex-torrent-download/ , It is about 20 Gb.

  2. I installed PlayOnLinux by terminal:

    playonlinux is already a newer version (4.2.12-1)

  3. I installed WineTricks by terminal:

    winetricks is already a newer version (0.0+20180217-1)

  4. I installed the msxml6 using WineTricks. (I needed it for running another software).

  5. I created a mounting folder named mnt/isomgp2015 for unpacking the ISO FILE of MotoGp2015 by terminal.

  6. I mounted the MotoGP2015 .iso file as follows:

    root@mau-HP:~/mnt/isomgp15# mount -o loop /home/mau/Escritorio/ISOMOTOGP15/mgp.iso /home/mau/mnt/isomgp15/
    mount: /home/mau/mnt/isomgp15: ATENCIÓN: el dispositivo está protegido contra escritura; se monta como sólo lectura.
    

Where /home/mau/Escritorio/ISOMOTOGP15/mgp.iso is the location of the ISO file and /home/mau/mnt/isomgp15/ the destination of the mounted iso.

(I am asking myself if the ATENCIÓN warning can be a problem?)

  1. I run the .exe file on PlayOnLinux

    First attempt MotoGp .exe on PlayOnLinux

    and got this message:

    runtime error 229 
    

    and I discover that the cause is because PlayOnLinux is running as Windows 7 as default windows version.

    Runtime error 229

  2. I then run the .exe file again in PlayOnLinux selecting Windows XP version and the install program launches! (it also launches with vista version)

    PlayOnLinux second attempt by XP

    Install wizard launches

    game successfully installed

See all files installed in the list below

  1. I followed the steps through the installation wizard and created some shortcuts on desktop.

    ShortcutsPlayOnLinux

  2. I copy-pasted the dll and other files for activation in the folder in the picture using PlayOnLinux following the website instructions from where I downloaded the ISO file (that works in genuine windows 10 environment).

    DLL and other files for crack]

  3. I launched the shortcut and Pol_WIne crashes and game does not start.

    Pol_Whine crashes

I also tried to install directX but that did not work.

  • 4
    I'm voting to close this question as off-topic because this is a Unix and not a Windows group. – Rui F Ribeiro Nov 6 '18 at 15:40
  • 1
    I would say this is definitely a question that fits here. It's asking about how to run something on linux. Even if that something is a Windows program, the question here is about play on linux. – darnir Nov 6 '18 at 23:15
0

I tried with motogp2013 and found a solution!

BUT HERE I FOUND THE SOLUTION!

1) Mount ISO as specified in the above post

2) Execute .exe on PlayOnLinux but chose 32bit during the install wizard

3) Chose Wine Version 1.6.2

4) Install directX from the Motogp launch wizard

5) Create a launch exe icon before closing the installation wizard of PlayOnLinux

6) Than select MotoGp2013 shortcut in the list of PlayOnLinux, right click and open the directory of the files. Go into the iso folder copy the 2 craked dll. GO back to Motogp2013 directory files and paste the 2 dll into the directory and say Yes for substituting old dll.

7) Go back to Playonlinx shortcuts and click in the left column "configuration"

8) And click the onto "install components".Install one after the other : wmp9 - quartz - devnum - directx9 You need to execute everything under 32bit version because wmp9 won't work under 64bit.

9) Run the game. Chose "windowed". Than Play. After few seconds the black screen appears. Click on the x button for closing the window. A message appears "do you wanna quit the game?"...of course not. Than continuing pressing Start button.

10 not tested but..."Joypad not working, solved by using software like qjoypad"

Here part of the details that led me to the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.