0

After upgrading to the 4.18 Linux kernel using Debian sid, I've been dealing with some sound issues that I haven't before the upgrade. After the laptop suspends, majority of the time (but not always) the sound does not work. I either have to completely shut down the machine or use the killall pulseaudio/pulseaudio --k commands which only work after I execute them half a dozen times.

DMESG LOG

  snd_hda_intel 0000:00:03.0: enabling device (0000 -> 0002)
[   11.752094] ACPI: Video Device [GFX0] (multi-head: yes  rom: no  post: no)
[   11.752520] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input9
[   11.754746] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   11.760675] iwlwifi 0000:02:00.0: firmware: direct-loading firmware iwlwifi-7265-17.ucode
[   11.761202] iwlwifi 0000:02:00.0: loaded firmware version 17.948900127.0 op_mode iwlmvm
[   11.761577] fbcon: inteldrmfb (fb0) is primary device
[   11.830634] input: HDA Intel HDMI HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:03.0/sound/card1/input10
[   11.830699] input: HDA Intel HDMI HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:03.0/sound/card1/input11
[   11.830755] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card1/input12
[   11.830816] input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card1/input13
[   11.830874] input: HDA Intel HDMI HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:03.0/sound/card1/input14
[   11.882029] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[   11.882035] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882045] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882102] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[   11.882106] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882113] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882167] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[   11.882171] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882179] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882238] input: HP WMI hotkeys as /devices/virtual/input/input15
[   11.882378] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[   11.882382] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882389] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882423] ACPI Error: Field [D128] at bit offset/length 128/1024 exceeds size of target Buffer (160 bits) (20180531/dsopcode-201)
[   11.882426] ACPI Error: Method parse/execution failed \HWMC, AE_AML_BUFFER_LIMIT (20180531/psparse-516)
[   11.882431] ACPI Error: Method parse/execution failed \_SB.WMID.WMAA, AE_AML_BUFFER_LIMIT (20180531/psparse-516)

[   50.738396] i2c_designware INT3433:00: timeout waiting for bus ready
[   50.738402] rt286 i2c-INT343A:00: I2C error -110

SYSLOG

Nov  4 19:15:02  kernel: [   11.994529] haswell-pcm-audio haswell-pcm-audio: firmware: failed to load intel/IntcPP01.bin (-2)
Nov  4 19:15:02  kernel: [   11.994531] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
Nov  4 19:15:02  kernel: [   11.994533] haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
Nov  4 19:15:02  kernel: [   11.994536] haswell-pcm-audio haswell-pcm-audio: fw image intel/IntcPP01.bin not available(-2)
Nov  4 19:15:02  kernel: [   11.995123] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
Nov  4 19:15:02  kernel: [   12.023525] kvm: disabled by bios
Nov  4 19:15:02  kernel: [   12.023535] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System Pin mapping ok
Nov  4 19:15:02  kernel: [   12.023588] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload0 Pin mapping ok
Nov  4 19:15:02  kernel: [   12.023630] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload1 Pin mapping ok
Nov  4 19:15:02  kernel: [   12.023669] broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Loopback Pin mapping ok

The other issue which is the most irritating is when switching the output device from speaker to headphones then back to speaker using pavucontrol, the volume completely messes up. Sound becomes extremely loud and incoherent. The same thing happens when I unmute and mute the headphone output in alsamixer.

cat /proc/asound/cards:

0 [broadwellrt286 ]: broadwell-rt286 - broadwell-rt286
                  HP-HPSpectrex360Convertible--802D
 1 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                  HDA Intel HDMI at 0xb2210000 irq 48
0

I solved the issue by editing

/etc/default/grub

On the following line I had

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

Keep whatever commands you have on that line but add this within the quotes

acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'

This is what I'm using

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor acpi_osi='!Windows 2013' acpi_osi='!Windows 2012'"

then

sudo update-grub

After that my sound card names changed

0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                  HDA Intel HDMI at 0xb2214000 irq 49
1 [PCH            ]: HDA-Intel - HDA Intel PCH
                  HDA Intel PCH at 0xb2210000 irq 46

I'm no longer receiving any syslog errors and after suspend my audio still works however one issue popped up and that's after plugging in headphones the speaker output doesnt return to its original volume. Headphones are muted but speakers remain at 0 which means you have to manually go to alsamixer and raise it, even with automute disabled. One way to fix that is going to

/usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

and editing

[Element Speaker]
switch = off
volume = off

to

[Element Speaker]
switch = off
volume = merge

Now so far everything works great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.