0

I'm trying to install Rabbit MQ in my system.

CentOS Linux release 7.5.1804 (Core)

To install RabbitMQ, I need to install Erlang first and for Erlang I need openssl-devel.

When I try to install openssl-devel through yum, I'm getting the below error. I understand removing the existing libcom_err package could break my system. Hope it's not advisable to remove the existing package and install older one.

So how can I fix this without fixing my breaking my machine ? I tried --skip-broken, but that just skips the Package.

         Error: Package: libcom_err-devel-1.42.9-11.el7.x86_64 (CentOSrepo)
           Requires: libcom_err(x86-64) = 1.42.9-11.el7
           Installed: libcom_err-1.42.9-12.el7_5.x86_64 (@updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Available: libcom_err-1.42.9-11.el7.x86_64 (CentOSrepo)
               libcom_err(x86-64) = 1.42.9-11.el7

enter image description here

  • Look like it's red hat, not centos. – Tuyen Pham Nov 4 '18 at 13:19
  • @TuyenPham CentOS Linux release 7.5.1804 (Core) – Manikandaraj Srinivasan Nov 4 '18 at 14:04
  • Do these commands: yum -y install epel-release and yum -y update; yum install rabbitmq-server, sudo if needed, does this help? – Tuyen Pham Nov 4 '18 at 15:57
  • Tried those, didn't work. – Manikandaraj Srinivasan Nov 4 '18 at 16:09
  • Can you elaborate? What command break and what is its output? and then update to 1st post. – Tuyen Pham Nov 4 '18 at 16:11
0

Can't comment, so adding as an answer. Did you add the epel repo? I tried installing the Rabbitmq-server package and it found the dependencies in the epel repo.

Dependencies Resolved

======================================================================================================================================
 Package                                 Arch                      Version                              Repository               Size
======================================================================================================================================
Installing:
 rabbitmq-server                         noarch                    3.3.5-34.el7                         epel                    4.0 M
Installing for dependencies:
 erlang-asn1                             x86_64                    R16B-03.18.el7                       epel                    758 k
 erlang-compiler                         x86_64                    R16B-03.18.el7                       epel                    1.0 M
 erlang-crypto                           x86_64                    R16B-03.18.el7                       epel                     86 k
 erlang-erts                             x86_64                    R16B-03.18.el7                       epel                    2.5 M
 erlang-hipe                             x86_64                    R16B-03.18.el7                       epel                    2.4 M
 erlang-inets                            x86_64                    R16B-03.18.el7                       epel                    800 k
 erlang-kernel                           x86_64                    R16B-03.18.el7                       epel                    1.1 M
 erlang-mnesia                           x86_64                    R16B-03.18.el7                       epel                    700 k
 erlang-os_mon                           x86_64                    R16B-03.18.el7                       epel                    115 k
 erlang-otp_mibs                         x86_64                    R16B-03.18.el7                       epel                     32 k
 erlang-public_key                       x86_64                    R16B-03.18.el7                       epel                    538 k
 erlang-runtime_tools                    x86_64                    R16B-03.18.el7                       epel                    179 k
 erlang-sasl                             x86_64                    R16B-03.18.el7                       epel                    293 k
 erlang-sd_notify                        x86_64                    0.1-1.el7                            epel                    9.1 k
 erlang-snmp                             x86_64                    R16B-03.18.el7                       epel                    1.5 M
 erlang-ssl                              x86_64                    R16B-03.18.el7                       epel                    588 k
 erlang-stdlib                           x86_64                    R16B-03.18.el7                       epel                    2.2 M
 erlang-syntax_tools                     x86_64                    R16B-03.18.el7                       epel                    336 k
 erlang-tools                            x86_64                    R16B-03.18.el7                       epel                    566 k
 erlang-xmerl                            x86_64                    R16B-03.18.el7                       epel                    998 k
 lksctp-tools                            x86_64                    1.0.17-2.el7                         base                     88 k

Transaction Summary
======================================================================================================================================
Install  1 Package (+21 Dependent packages)

On another note, I can see that listing libcom_err shows the current version as 1.42.9-11.el7 and the update as 1.42.9-12.el7_5. why don't you try updating the package and let yum figure out the dependencies.

[root@centoserv ~]# yum list libcom_err
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.infinity.iq
 * epel: del-repos.extreme-ix.org
 * extras: centos.mirror.infinity.iq
 * updates: centos.mirror.infinity.iq
Installed Packages
libcom_err.x86_64                                              1.42.9-11.el7                                                 @anaconda
Available Packages
libcom_err.i686                                                1.42.9-12.el7_5                                               updates
libcom_err.x86_64                                              1.42.9-12.el7_5                                               updates
[root@centoserv ~]#

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.