2

I had a RAID1 setup (md0), mirroring two 2TB drives (sdb, sdc). When trying to remove the RAID to use the disks individually with the data on them, I ran

mdadm --stop /dev/md0
mdadm --zero-superblock /dev/sdb1
mdadm --zero-superblock /dev/sdc1
mdadm --remove /dev/md0

However, afterwards, if I want to mount /dev/sdb1, I get the following: "wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error".

On my attempts to recreate the ext4 file system, I think I already nuked sdc beyond recovery (I ran mkfs.ext4 /dev/sdc1).

Is there still hope for me to recover my data from sdb and if so how?

9
  • Very carefully make a backup of the corrupted drive. Please excercise Extreme Caution: dd if=/dev/sdb of=/dev/blankdrive Then you can play around with trying to recover the journal structure, partition tables, etc.
    – jmunsch
    Nov 3 '18 at 16:16
  • Good call, I have it backed up and hope that someone can point me to a potential way of recovery. Thanks!
    – gro
    Nov 3 '18 at 17:23
  • what's the output of mdadm --examine /dev/sdb1 ? also see: unix.stackexchange.com/a/72285/61110
    – jmunsch
    Nov 3 '18 at 17:29
  • mdadm: No md superblock detected on /dev/sdb1. EDIT: And guessing the offset didn't work :p
    – gro
    Nov 3 '18 at 17:33
  • 1
    maybe this might be a better example: unix.stackexchange.com/questions/64889/… i was thinking it might be possible to mount it based on some kind of offset.
    – jmunsch
    Nov 5 '18 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.