0

When I boot Deepin 15.7, it for some reason seems to refuse to show anything onscreen without a HDMI connection - even if the screen's off.

NOTE - It shows GRUB, then when I select Deepin and log in, the cursor does a load and then the screen switches off until I connect HDMI.

I suspect it's in the settings, since it began when I was messing and rotated the screen.

EDIT: Here's the ~/.config/startdde/display.json config

{
  "eDP343f3a0f165a07b1e6f43f9e3f474d1d": {
    "Name": "",
    "Primary": "eDP-1",
    "BaseInfos": [
      {
        "UUID": "eDP343f3a0f165a07b1e6f43f9e3f474d1d",
        "Name": "eDP-1",
        "Enabled": true,
        "X": 0,
        "Y": 0,
        "Width": 2880,
        "Height": 1620,
        "Rotation": 2,
        "Reflect": 0,
        "RefreshRate": 59.96025750906705
      }
    ]
  }
}
  • @Rui You deleted the last part, without it this would be a duplicate – R Harrington Nov 3 '18 at 8:48
  • I doubt it will won' t be even with it, but feel free to add it. I usually advise keeping on topic and keep it shorter. You seem to have added some technical data, congrats. – Rui F Ribeiro Nov 3 '18 at 8:50
  • @Rui Will or won't? (Not clear) – R Harrington Nov 3 '18 at 14:48
0

Seems to work fine when I set ~/.config/startdde/display.json :

{
  "My Settings 1+eDP343f3a0f165a07b1e6f43f9e3f474d1d,HDMI20cde46b179d940d99eb2a8cbbe8eb43": {
    "Name": "My Settings 1",
    "Primary": "eDP-1",
    "BaseInfos": [
      {
        "UUID": "eDP343f3a0f165a07b1e6f43f9e3f474d1d",
        "Name": "eDP-1",
        "Enabled": true,
        "X": 0,
        "Y": 0,
        "Width": 3200,
        "Height": 1800,
        "Rotation": 0,
        "Reflect": 0,
        "RefreshRate": 59.99977415600772
      },
      {
        "UUID": "HDMI20cde46b179d940d99eb2a8cbbe8eb43",
        "Name": "HDMI-1",
        "Enabled": false,
        "X": 3200,
        "Y": 0,
        "Width": 1920,
        "Height": 1080,
        "Rotation": 1,
        "Reflect": 0,
        "RefreshRate": 60
      }
    ]
  },
  "eDP343f3a0f165a07b1e6f43f9e3f474d1d": {
    "Name": "",
    "Primary": "eDP-1",
    "BaseInfos": [
      {
        "UUID": "eDP343f3a0f165a07b1e6f43f9e3f474d1d",
        "Name": "eDP-1",
        "Enabled": true,
        "X": 0,
        "Y": 0,
        "Width": 2880,
        "Height": 1620,
        "Rotation": 0,
        "Reflect": 0,
        "RefreshRate": 59.96025750906705
      }
    ]
  }
}

It seems the display reverted to this, and I change "Rotation"to 0 not 2, effectively undoing what I did previously. I also disabled HDMI, but it works fine with it on

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.