0

OS: 2.6.32-696.23.1.el6.x86_64 (Centos 6)

Sendmail: 8.14.4

sendmail will receive mail for local users from outside users but queue it and not deliver it promptly but in spurts; sample receipt line:

Nov 1 15:56:17 server sendmail[18406]: wA1JqHk8018406: to=, delay=00:00:00, mailer=local, pri=83669, dsn=4.4.3, stat=queued

Then:

Nov 1 22:50:31 server sendmail[19747]: wA1JqHk8018406: to=, delay=06:54:14, xdelay=00:00:00, mailer=local, pri=713669, dsn=2.0.0, stat=Sent

At that time 27 other messeges were marked as 'stat=Sent'.

Any useful sendmail commands to debug this one? Things to check in the .mc or .cf files?

I should mention that I am getting the following message in the initial transaction:

Nov 1 15:56:18 server sendmail[18406]: STARTTLS: write error=syscall error (-1), errno=104, get_error=error:00000000:lib(0):func(0):reason(0), retry=99, ssl_err=5

There's not much I can find about this error, except to use ssldump. I don't know whether it is relevant to the main problem.

  • 1
    Could you post DeliveryMode option and Mlocal (local mailer) lines from your /etc/mail/sendmail.cf file? – AnFi Nov 2 '18 at 15:36
  • check out the DSN error codes here. – meuh Nov 2 '18 at 17:29
0

It seems like you need to dig through the .cf file and the .config file and edit lines like

QUEUE_INTERVAL="10m"; 

If you set enough of these low hopefully it will fix the speed setting.

To debug have one window with command below running

while true; do mailq; sleep 1s; done 

check how fast things enter and leave the q Try running with wire shark capturing the network session on your sender and receiver this will help you determine whether there is network latency involved.

try running with these flags

-N 'delay, success, failure'
-X logfile.log
-bv 

Also try

postconf readme_directory or postconf html_directory 

In order to find the DEBUG_README Which is very useful for Debugging

  • Default sendmail configuration conducts "at once" delivery attempts. – AnFi Nov 3 '18 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.