2

I'm trying to build a ftp server, but got stuck with logging problem 530.

Here are my configs:

vsftpd.conf

[root@### vsftpd]# cat vsftpd.conf | grep "^[^#]"
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
anon_upload_enable=NO
anon_mkdir_write_enable=NO
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=NO
xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
idle_session_timeout=1800
data_connection_timeout=300
nopriv_user=virtual
async_abor_enable=YES
ascii_upload_enable=YES
ascii_download_enable=YES
ftpd_banner=Welcome to blah FTP service.
chroot_local_user=NO
chroot_list_enable=NO
chroot_list_file=/etc/vsftpd/chroot_list
ls_recurse_enable=NO
listen=YES
listen_ipv6=NO
pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
userlist_deny=NO
guest_enable=YES
guest_username=virtual
virtual_use_local_privs=YES
user_config_dir=/etc/vsftpd/user_config
pasv_enable=YES
pasv_min_port=3000
pasv_max_port=3010
check_shell=NO
use_localtime=YES
userlist_file=/etc/vsftpd/user_list
local_root=/home/virtual

user_list file

[root@### vsftpd]# cat user_list
# vsftpd userlist
# If userlist_deny=NO, only allow users in this file
# If userlist_deny=YES (default), never allow users in this file, and
# do not even prompt for a password.
# Note that the default vsftpd pam config also checks /etc/vsftpd/ftpusers
# for users that are denied.
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
nobody


www
visual
zw
wwwftp

virtual account config wwwftp

[root@### vsftpd]# cat /etc/vsftpd/user_config/wwwftp
local_root=/home/virtual
anonymous_enable=NO
write_enable=YES
local_umask=022
anon_upload_enable=NO
anon_mkdir_write_enable=NO
idle_session_tiemout=1800
data_connection_timeout=600
max_clients=10
max_per_ip=5
local_max_rate=1048576

/etc/pam.d/vsftpd

[root@### vsftpd]# cat /etc/pam.d/vsftpd
#%PAM-1.0
auth sufficient /usr/lib64/security/pam_userdb.so db=/etc/vsftpd/virtual_users.db
account sufficient /usr/lib64/security/pam_userdb.so db=/etc/vsftpd/virtual_users.db

success in connecting to the server, responds with:

connected to 39.*.*.*          # here is my server ip

220 Welcome to blah FTP service.

User(39.*.*.*:(none)):wwwftp

331 Please specify the password

Password:

530 Login incorrect
  • welcome to U&L, where did you set password for wwwftp ? – Archemar Nov 2 '18 at 14:18
  • A strace tool can help a lot, I strongly suggest to learn it ASAP. – peterh - Reinstate Monica Nov 4 '18 at 21:30
0

See if you can login to the terminal with the account. If not, check the output of /var/log/messages /var/log/auth.log or similar to see what the issue is.

Not the answer you're looking for?Browse other questions tagged or ask your own question.