1

I have one server at packet.net and I have attached external volume which is mounted to folder /BACKUP where I process backup. Yesterday I have received an email that there is a problem with main partition - it is almost full? Somehow, attached volume de-attaches and mount /BACKUP was (I guess) unmounted and several backups was done in this folder which "switches" to local drive. When I attach external volume again, /BACKUP folder was automatically mounted to it. I delete all files on it, but main partition still shows it is full 90%.

When I check with df, I see this result:

[root@packet /]# df
Filesystem                    1K-blocks     Used Available Use% Mounted on
/dev/sda3                      74824932 64793724   6207284  92% /
devtmpfs                        4069428        0   4069428   0% /dev
tmpfs                           4081476        4   4081472   1% /dev/shm
tmpfs                           4081476   123644   3957832   4% /run
tmpfs                           4081476        0   4081476   0% /sys/fs/cgroup
tmpfs                            816296        0    816296   0% /run/user/10003
tmpfs                            816296        0    816296   0% /run/user/0
/dev/mapper/volume-1cb9df94p1  61795116    53704  58579352   1% /BACKUP

the I wanted to find where those 3 backups gone, and searched for large folders.

[root@packet /]# du -a / | sort -n -r | head -n 5
26593808        /
17031172        /var
13973568        /var/www
13968748        /var/www/vhosts
8188140 /var/www/vhosts/xxxxxxx.com

So it looks like / folder is large 26 Gb (which should be correct), but in df it shows 64 Gb occupation, like those three backups (~12Gb each) vanishes... How to fix this problem?

4

They seem to still be in the /BACKUP folder. When you mount the drive, what was in the folder is now hidden by the mount point. to remove the hidden files you will need to unmount /BACKUP and rm /BACKUP/* the files after unmounting.

  • when I attached volume back, there were files that were originally on the drive. Not yet tried to unmount and mount again – Војин Петровић Nov 1 '18 at 14:54
  • yep, when I umount /BACKUP I found files back. Deleted all of them and now is OK. I just cant mount back because "mount: /dev/sdc is already mounted or /BACKUP busy" but will find out how to manage that (I guess). It is not mounted, checked, but it is Busy... – Војин Петровић Nov 1 '18 at 15:07
  • 1
    @ВојинПетровић leave the directory and it will stop being busy – Rui F Ribeiro Nov 1 '18 at 15:08
  • I'm not in a directory :) I have tried to mount it to newly created folder /BKP, but it is still busy – Војин Петровић Nov 1 '18 at 15:10
  • I have tried now to mount it to /BKP, but same error. When I list all mounts there is no sdc in mounts – Војин Петровић Nov 1 '18 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.