I am trying to install ScicosLab on Scientific Linux 7 and have run into package dependency issues. I am moderately skilled with Ubuntu but have no experience with Scientific Linux or anything like it. I download the .rpm file from ScicosLab's site and run yum localinstall scicoslab-gtk-4.4.1-1.sl6.x86_64.rpm as root. It gives me an error:

Error: Package: scicoslab-gtk-4.4.1-1.x86_64 (/scicoslab-gtk-4.4.1-1.sl6.x86_64)
           Requires: libwebkit-1.0.so.2()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have tried to install this package but cannot seem to get it...


So here's what I did. I did a minimal install of Scientific Linux 7.5 in Virtualbox. I tried installing this package and got the same error. After some searching around this is how I managed to fix it.

I installed the epel repository.

yum install epel-release

I added the Scientific Linux 6.10 repo as the specific webkitgtk, libicu and libxcb versions required by this package were found there.

[root@scinlinux ~]# cat /etc/yum.repos.d/sci610.repo
name=Scientific Linux 6.10 repo
[root@scinlinux ~]#

After that the package got installed without any problems. In the below output I've displayed the packages that were fetched from the epel and sci-6.10 repos.

[root@scinlinux ~]# yum install /tmp/scicoslab-gtk-4.4.1-1.sl6.x86_64.rpm
Examining /tmp/scicoslab-gtk-4.4.1-1.sl6.x86_64.rpm: scicoslab-gtk-4.4.1-1.x86_64
Marking /tmp/scicoslab-gtk-4.4.1-1.sl6.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package scicoslab-gtk.x86_64 0:4.4.1-1 will be installed
 libicu                                 x86_64         4.2.1-14.el6                   sci_6.10                                  4.9 M
 libxcb                                 x86_64         1.12-4.el6                     sci_6.10                                  179 k
 vte                                    x86_64         0.28.2-10.el7                  epel                                      361 k
 webkitgtk                              x86_64         1.4.3-9.el6_6                  sci_6.10                                  6.3 M

Note that in the below output the repos other than epel and sci_6.10 were already installed when Sci_linux 7.5 was installed.

[root@scinlinux ~]# yum repolist
repo id                                          repo name                                                                      status
*epel/x86_64                                     Extra Packages for Enterprise Linux 7 - x86_64                                 12,756
repos/x86_64                                     Scientific Linux repos - x86_64                                                    20
sci_6.10                                         Scientific Linux 6.10 repo                                                      6,860
sl/x86_64                                        Scientific Linux 7x - x86_64                                                    9,957
sl-extras/x86_64                                 Scientific Linux Extras - x86_64                                                1,066
sl-fastbugs/x86_64                               Scientific Linux 7x - x86_64 - bugfix updates                                   1,013
sl-security/x86_64                               Scientific Linux 7x - x86_64 - security updates                                   637
repolist: 32,309
[root@scinlinux ~]#
  • What would be the best way to add that SL 6.10 repository? I have tried to run yum-config-manager --add-repo http://ftp.scientificlinux.org/linux/scientific/6.10/x86_64/os/ but your second step shows nothing there. Oct 31 '18 at 19:59
  • You can just create the below file. [root@scinlinux ~]# cat /etc/yum.repos.d/sci610.repo [sci_6.10] name=Scientific Linux 6.10 repo baseurl=http://ftp.scientificlinux.org/linux/scientific/6.10/x86_64/os/ gpgcheck=0 [root@scinlinux ~]#
    – rav
    Nov 1 '18 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.