0

I want install ansible on server without internet and I have this error :

Error: Package: 1:openssl-devel-1.0.1e-60.el7.x86_64 (@local-repo)
           Requires: openssl-libs(x86-64) = 1:1.0.1e-60.el7
           Removing: 1:openssl-libs-1.0.1e-60.el7.x86_64 (@anaconda)
               openssl-libs(x86-64) = 1:1.0.1e-60.el7
           Updated By: 1:openssl-libs-1.0.2k-12.el7.x86_64 (local-repo)
               openssl-libs(x86-64) = 1:1.0.2k-12.el7
Error: Package: 1:openssl-perl-1.0.1e-60.el7.x86_64 (@local-repo)
           Requires: openssl(x86-64) = 1:1.0.1e-60.el7
           Removing: 1:openssl-1.0.1e-60.el7.x86_64 (@anaconda)
               openssl(x86-64) = 1:1.0.1e-60.el7
           Updated By: 1:openssl-1.0.2k-12.el7.x86_64 (local-repo)
               openssl(x86-64) = 1:1.0.2k-12.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

i have openssl-1.0.1e-60.el7.x86_64 and openssl-libs-1.0.1e-60.el7.x86_64 in my local repository but i can't update .

1 Answer 1

1

The problem is yum isn't too smart. You are trying to install openssl-devel-1.0.1e-60 so yum detects that he also needs to install openssl-libs. He detects that a newer version of openssl-libs can be installed, but that conflicts with openssl-devel-1.0.1e-60...

There are two possible solutions:

  • make sure openssl-devel-1.0.2k-12.el7.x86_64 is available in your local repositories
  • force yum to install the older openssl-libs package: yum install openssl-devel-1.0.1e-60 openssl-libs-1.0.1e-60 openssl-1.0.1e-60

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .