0

I'm in the process of running some Machine Learning algorithm that needs all my GPU. As such I want to leave it running during the night with X server off as to let all the GPU RAM available to my ML code.

To shutdown X I open TTY 2 and do sudo systemctl stop sddm (my OS is Kubuntu 18.04.1).

Unfortunately my dual monitor setup is right in front of my bed and I cannot sleep at night without turning my monitors off.

Problem: when I try to turn them on in the morning I get a "no video signal. Going into sleep mode" kind of message and no TTY is shown. I try to Ctrl+Alt+FX and type my login and setterm -blank 0 -poweroff -0 but the screen does not show any TTY, it just keep saying that there is no video signal and it will continue sleeping.

I have already set consoleblank=0 in my grub command line.

cat /sys/module/kernel/parameters/consoleblank

returns 0.

As far as I can tell consoleblank is working fine if I do not turn the monitors off (i.e. after 20+ minutes of no interaction with the computer while cleaning my flat I can still see the TTYs fine).

The monitors are Dell UltraSharp U2515H. I tried to remove the powerchord from the monitor, wait 20 seconds and re-plugging it as suggested by some people saying this will reset something about power saving but the result hasn't changed: no TTY shown only the message "no video signal".

My monitors are connected via DisplayPort directly to the GPU.


$ inxi -SGx
System:    Host: state-monad Kernel: 4.15.0-38-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: KDE Plasma 5.12.6 (Qt 5.9.5) Distro: Ubuntu 18.04.1 LTS
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1080] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 2560x1440@59.95hz, 2560x1440@59.95hz
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 version: 4.6.0 NVIDIA 410.66 Direct Render: Yes

$ cat /usr/share/X11/xorg.conf.d/10-nvidia.conf 
Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
EndSection

$ cat /etc/default/grub 
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash libata.allow_tpm=1 consoleblank=0"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.