0

I'm using neomutt as my mail client, in Gnome Terminal 3.28.2 on Ubuntu 18.04. I'd like to open inline URLs in a Firefox Private Window by default -- right now they open a new tab in an existing, non-Private Window.

I can do this in my mailcap with the -private-window flag, but that won't work for just selecting "open link" from the gnome-terminal context menu.

There's a Mozilla support thread from an OSX user asking how to do this globally and the answer appears to be that you can't, but I'm on Ubuntu and tbh only need this to work from neomutt running in a terminal.

  • but that won't work for just selecting "open link" from my context menu. How are you doing this exactly? Right-clicking on the link in the terminal? If so, then it's the terminal emulator's context menu, and nothing to do with neomutt. – Sparhawk Oct 27 '18 at 4:41
  • Yes, I'm getting the context menu by right-clicking on the URL in my terminal. Will edit the question. – Amanda Oct 27 '18 at 21:08
  • I suspect that the answer is that "you can't", at least just for neomutt and Gnome terminal. It looks like Gnome Terminal just uses the "default" web browser setting. You could possibly hack this to always use private windows, but then every single link (from all programs that use the default) would be opened in a private window. – Sparhawk Oct 27 '18 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.