0

I followed the instructions for installing Whonix on Linux and I got stuck at installing Virtualbox from Debian backports. I get the following errors after step 3 (here):

W: GPG error: http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
E: The repository 'http://http.debian.net/debian stretch-backports InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried to replace the recommended line

sudo su -c "echo -e 'deb http://http.debian.net/debian stretch-backports main contrib' > /etc/apt/sources.list.d/backports.list"

with

sudo su -c "echo -e 'deb http://ftp.debian.org/debian stretch-backports main' > /etc/apt/sources.list.d/backports.list"

I got that information from the Debian website: https://backports.debian.org/Instructions/

Note: I removed the old backports.list before adding the new with following command:

sudo rm /etc/apt/sources.list.d/backports.list

Well I get quite the same error with the recommended instructions on the Debian site. I wonder now, what to do. Can't I just install virtualbox from the Ubuntu repo? It's a little confusing, since the references on the whonix page at the end of the line "Package virtualbox should be installed from Debian backports." are not working. The browser is just jumping at the top of the site.

0

These instructions are for Debian. Backports only required in case of Debian since VirtualBox is unavailable in stretch.

Please install VirtualBox using the usual mechanisms of your Linux distribution.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.