0

I just upgraded OpenSUSE from Leap 42.3 to Leap 15.0, and with this upgrade, OpenSUSE moved its default firewall application from SuSEfirewall2 to Firewalld. I opted not to use the susefirewall2-to-firewalld script for migration, but to rebuild my rules from scratch. However, I cannot seem to allow NetBIOS queries to return successfully on my client machine. I have enabled both the samba and samba-client services in Firewalld.

For a host hostname, which I can ping because of DNS or access by IP address, and from which I can access my OpenSUSE machine via Samba, I try:

> nmblookup hostname
name_query failed to find name hostname

What else do I need to do to allow a NetBIOS query to succeed?

-1

As a result of a discussion about this issue from the Fedora Mailing-Lists, I added port 137 UDP to the Source Port list for the samba-client Service in Firewalld (with the firewall-config tool), which enabled the nmblookup call to succeed.

firewalld configuration, with the firewall-config tool

  • -1 until someone can convince me this isn't allowing any incoming UDP packet which has a source port of 137. I guess NMBIOS stuff doesn't get connection-tracked properly because of the use of broadcast packets. – sourcejedi Feb 19 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.