2

I am running Debian 8.11 inside a XEN Guest. In the syslog there are the following messages which get repeated every few seconds:

dbus[]: [system] Failed to active service 'org.freedesktop.systemd1': timed out 
systemd[]: systemd-logind.service: main process exited, code=exited, status=1/FAILURE 
systemd[]: Failed to start Login Service.
systemd[]: Unit systemd-logind.service entered failed state
systemd[]: systemd-logind.service has no holdoff time, scheduling restart
systemd[]: Stopping Login Service...
systemd[]: Starting Login Service...

I found several bug reports so I tried apt-get update && apt-get upgrade but unpacking procps always fails with

Failed to execute operation: Connection timed out

I also tried to just upgrade systemd but I get the same result.

Most systemctl commands will return a 'Connection timed out' message.

Running SYSTEM_LOG_LEVEL=debug /lib/systemd/systemd-logind returns the following:

... Sent message type=method_call sender=n/a destination=org.freedesktop.systemd1 object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=Subscribe cookie=7 reply_cookie=0 errror=n/a
Failed to enable subscription: Activation of org.freedesktop.systemd1 timed out
Failed to fully start up daemon: Connection timed out

There was a power failure a few days ago, but all other guests and dom0 are running fine.

How can I fix this error?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.