6

I tried a solution mentioned in the question: getting Checkpoint VPN SSL Network Extender working in command line (the accepted answer), but for some reason I'm getting an authentication failed error.

I can access through the web browser to the Checkpoint portal with the credentials I have, but not with the snx tool.

What I've done:

  1. installed the Root CA certificates of the VPN;
  2. installed the snx_install.sh on my machine with success;
  3. also installed the python tools you recomended but I think I didn't need them.

What I have:

  • My system is Linux Mint 19 (based on Ubuntu 18);
  • I've Check Point's Linux SNX build 800007097.

What I tried:

running the snx tool both with arguments and with config file (.snxrc) and both gave the error:

SNX: Authentication failed

My.snxrc file has this (user and server are illustrative ):

server MYVPNSERVER
username MYUSER
reauth yes

Important note: is not the user and password since I can do connect using a Windows 10 VM with checkpoint software.

5

Checkpoint has discontinued (official) support for their snx client, on the Linux command line, a couple of years ago.

Use of snx has not been supported from the command line after version 800007075 (from 2012) ; newer versions only work officially when invoked from a Java Applet, supplied when browsing the Checkpoint appliance.

Per my post, that you are linking to in your question, 800007075 is the last one having the routines for doing the VPN full setup/configuration in Linux/Debian derivates from the command line. Maybe my fault, in that I am not entirely clear on that.

So, the snx version 800007097 you are using, won't work, when trying to connect to the VPN from the command line.

Newer versions might work, with snxconnect to complement the missing routines in the newer snx versions (hence the python tools), however the reverse engineering of the missing snx functionalities still presents some peculiarities. So, I recommend using the older version, that does not need the python tools.

I have been using snx version 800007075 for months now, with Debian Stretch, and it has been working pretty well.

TLDR

The 800007075 works without the snxconnect python instructions. The newer/your version needs the python hack/tools.

For using the CheckPoint snx program in the command line, without the python tools, you do not download the snx client that comes with your firewall appliance.

You have got to download the old 800007075 version, separately from here https://starkers.keybase.pub/snx_install_linux30.sh?dl=1 ; then follow getting Checkpoint VPN SSL Network Extender working in the command line, for setting it up with more modern version of Debian derivates.

PS. A workmate using the version of Ubuntu your Mint is based, followed my instructions last week using the snx version 800007075, and has been working fine. (as mentioned, I am using it myself in AntiX/Debian Stretch)

PPS. Taken from the Arch Linux AUR repositories scripts Package Details: snx-800007075 800007075-1, you can also get the 800007075 Checkpoint VPN client at https://starkers.keybase.pub/snx_install_linux30.sh?dl=1

PPPS. The link in this answer for downloading the VPN client does not working anymore. Edited to replace it with the link mentioned in PPS

| improve this answer | |
  • Good to know, congrats. As it is in Linux, also doing other tricks with it, not as much constrained as in Windows ;) – Rui F Ribeiro Oct 25 '18 at 17:26
  • If I could upvote this answer a thousand times, manually, I would do it. – blueFast Feb 11 '19 at 9:30
  • @dangonfast Thanks for your support! You will be interested in this one too for the steps to install the client: unix.stackexchange.com/questions/450229/… – Rui F Ribeiro Feb 11 '19 at 11:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.