0

I know how to start a GNOME session in a console tty under Wayland (original source) and also the LANG=en-US trick that usually works in Linux applications.

Now from the previously linked source I tried this command:

LANG=en-US XDG_SESSION_TYPE=wayland dbus-run-session gnome-session

It did not work and returned me some errors ending with:

fusermount: failed to access mountpoint /run/user/1000/gvfs: Permission denied
A connection to the bus can't be made

Running it with my system's configured language did work, however.

My use case is just that I'd like to make screenshots of some GNOME built-in messages/GUI elements itself (that are not part of any program, such as gnome-control-center. To be more useful (for an international reader/viewer) I'd like to get/use the English version of these. Temporarily of course, I am not keen on changing my system's language in the settings back and forth. Usually that way with LANG=en-US it works so smoothly.


This question has been cross-posted on ask.fedoraproject.org.

  • Sounds like an XY problem... For your use case you just launch the program with the desired locale in your current session e.g. LANG=en_US.UTF-8 gnome-control-center and you'll get g-c-c with en_US interface... – don_crissti Oct 23 '18 at 18:31
  • Well… be assured that in my case, it was really about GNOME/the actual gnome-shell. Nevertheless, a good tip. :) – rugk Jan 23 at 15:09
  • I actually explicitly stated that it e.g. is not gnome-control-center. – rugk Jan 23 at 15:28
0

Actually the solution has been posted on AskFedora by @johanh:

LANG=en_US.UTF8 dbus-run-session -- gnome-shell --display-server --wayland

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.