0

When I press Shift for 8 seconds (as the upcoming dialog says, I rather feel these are 10 seconds) GNOME enables "slow keys", how they call it.

Fortunately a dialog pops up before it is finally enabled. However that cannot be quickly dismissed by navigation with the keyboard (you can only click on "Cancel", moving with the keyboard's arrow keys does not work) or by pressing ESC. I found out, however, that you can close it by holding ESC for several seconds, too. (I would add a screenshot of that prompt here, but unfortunately this is not possible to screenshot it.)

My use case is just gaming on Linux or stuff like this, where it is perfectly fine when you hold the shift key for a longer time. As such, I do not want this dialog to pop up and dismissing it in the middle of a game is also very annoying.

As such my question is: How can I disable this prompt for enabling the keystroke delay?


The help file already linked above does state there is a setting for it:

Under Enable by Keyboard, select Turn on accessibility features from the keyboard to turn slow keys on and off from the keyboard. When this option is selected, you can press and hold Shift for eight seconds to enable or disable slow keys.

However, the mentioned setting is already disabled in my case: Setting "Enable by keyboard" with description "Turn accessibility features on and off using the keyboard" is shown in disabled state with a slider in "Off" position. Title of the window: "Typing Assist"

GNOME 3.28.2, Fedora 28


This question has been cross-posted on ask.fedoraproject.org.

  • What's the output of dconf read /org/gnome/desktop/a11y/keyboard/enable ? – don_crissti Oct 23 '18 at 18:12
  • @don_crissti It's "false". – rugk Oct 23 '18 at 18:18
  • That's how it should be, so it does not look like a configuration problem to me. I can't replicate that behavior on arch linux (pressing SHIFT even for more than 10 secs has no effect). – don_crissti Oct 23 '18 at 18:22
  • Okay, reported this as a bug. – rugk Oct 23 '18 at 18:45
0

Just to close this question as answered: In the question you can see how to do it, it is actually possible in the visible settings application.

There only was a bug that prevented this from working correctly in GNOME 3.28 at least, and has been fixed (to be released in v3.32, I guess.).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.