-1

I have several problems with virtualbox on fedora 28 workstation. Problems are described below:

First at all, I tried to install virtualbox following to this tutorial: https://www.if-not-true-then-false.com/2010/install-virtualbox-with-yum-on-fedora-centos-red-hat-rhel/

I got stuck at step 5: Install VirtualBox Latest Version 5.2

After command:

 dnf install VirtualBox-5.2

I got error: No match for argument: VirtualBox-5.2 Error: Unable to find a match.

I resolved this problem as described below:

I download rpm package from official site and install it with right clicking on it and choose open with software install

After successful installation I created vm with win10 64bit and tried to run it and then I get this:

enter image description here

Of course I run /sbin/vboxconfig in terminal as described in modal window but I got error : vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

output from dmesg: (there are more ECPI errors) enter image description here

After small research I found this article (https://gorka.eguileor.com/vbox-vmware-in-secureboot-linux-2016-update/), which looks like can solve my problem:

So I followed steps

I skipped first command because I already installed all required packages from this tutorial (virtualbox, gcc and kernel-devel)

Then I tried second command :

sudo akmods and get: No akmod packages found, nothing to do. [ OK ]

After trying third command:

sudo modprobe -v vboxdrv

ERROR: could not insert 'vboxdrv': Operation not permitted

So I couldnt continue....

Questions:

  1. What should cause : No match for argument: VirtualBox-5.2 Error: Unable to find a match. ???

2.How Could I solve errors produced by commands sudo akmods and sudo modprobe -v vboxdrv to get same result as in tutorial ?

3.I also encoutered to this Failed to synchronize cache for repo 'virtualbox', disabling. What does it mean ? and how could be solved ?

My virtualbox/kernel version is:

virtualbox - v5.2.20

fedora kernel version 4.18.14-200.fc28.x86_64.

  • The error said that you should use dmesg to find out why the vboxdrv module didn't load. But I don't see any dmesg output in your question. Please run dmesg -w in one terminal, then run vboxconfig in another terminal. If it fails, you will see new messages in the first terminal, and you can copy them here. – Michael Hampton Oct 23 '18 at 15:05
  • @MichaelHampton post is updated – Morty Oct 23 '18 at 19:33
  • Are you sure those are the right messages? The system was only up for 16 seconds. That's not enough time for you to have opened terminals and run vboxconfig. – Michael Hampton Oct 23 '18 at 19:34
  • here is whole output pastebin.com/0Xza2DbY – Morty Oct 24 '18 at 11:43
0

You can't run VirtualBox and KVM at the same time. But your system appears to be starting KVM at boot.

Try stopping and disabling the libvirtd service.

systemctl stop libvirtd
systemctl disable libvirtd

You can then either unload the KVM modules or reboot the system.

rmmod kvm_intel; rmmod kvm

At this point you should be able to install the VirtualBox modules and begin using VirtualBox.


But of course, if you are already using KVM, why on earth would you even want VirtualBox?

  • I didn't know about kvm I will try to use this instead of virtualbox – Morty Oct 24 '18 at 15:08
  • You can install virt-manager to have a nice GUI tool to create your VMs. – Michael Hampton Oct 24 '18 at 15:14
  • I finally found the time and install win 10 iso with kvm. Virt manager is great tool for managing VM. Thanks a lot ! So I solved my issue. Anyway I asked my colleague and he told me that he hasn't problem with virtualbox installation. – Morty Nov 6 '18 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.