0

What would cause a fresh install of Debian 9.5 to boot directly to the grub2 command line instead of the grub menu? Typing 'exit' at the prompt will take me into the menu where I can boot the system without issue. But for some reason, the default behavior is to boot to the grub command line.

I don't see any option that I can set in /etc/default/grub to override this behavior.

  • Just a wild guess: Installed grub2 to two harddrives ie. sda and sdb. Booting sda to empty grub menu, after exiting grub booting from sdb which actually works... = Change boot sequence in bios. – Michael D. Oct 22 '18 at 13:45
  • Unfortunately, no. It's a single disk. I chose not to partition during the install so /boot is part of the root partition. There was no option during the install (that I saw anyway) to configure grub, either. – NevDull Oct 22 '18 at 18:14
0

You can try to install grub again from commandline as root.

I assume your devid is /dev/sda but it could be different.

Check fdisk -l and/or parted -l first. Make sure not to grub-install to a partition like /dev/sda1.

Example:

grub-install /dev/sda
grub-install --recheck /dev/sda
update-grub
  • That's actually the first thing I tried after booting back into the OS. Since my disk is an NVME SSD, the device is recognized as /dev/nvme0n1. – NevDull Oct 23 '18 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.