I used to use Kitty X11 forwarding by simply launching a GUI application from the command line. This used to simply start a new program in my windows taskbar which would behave similar to windows application. However, now, it gives the error: KiTTY X11 proxy: unable to connect to forwarded X server: Network error: Connection refused. I know I can start a VcxSrv server to handle this but it doesn't give me the same behaviour (with a new window being spawned for each application I run). I also don't wish to install any new applications. How can I recover the old behaviour?


It is impossible for Windows to handle X11 windows with just KiTTY X11 forwarding alone: you must have had some Windows X server program configured to auto-start on login, before you started to get those error messages from the KiTTY X11 proxy.

VcXsrv has multiple different operating modes:

  • multiple X11 windows (which matches the description of what you used before)
  • full-screen (= no Windows taskbar visible at the bottom)
  • one large window (= all X11 windows inside one large window which has a normal Windows-style title bar)
  • one large window without titlebar (= can be almost like full-screen, but leaving the Windows taskbar visible)

It sounds like the default operating mode of VcXsrv may have been changed for some reason.

Please see the last picture at the bottom of this webpage, titled Select different VcXsrv Display Settings. According to it, there should be an XLaunch application that came with VcXsrv: it can be used to start VcXsrv in a different mode. It can also be used to save the VcXsrv configuration into a .xlaunch file: once you have the VcXsrv configuration you like saved into a file, you could arrange that file to auto-start at login, giving you the same user experience you had before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.