0

I have set up a vsftp server with anonymous access. vsftpd.conf contains the following:

anon_root=/var/www/ftp/
secure_chroot_dir=/var/www/ftp
local_root=/var/www/ftp

After login in as anonymous, the ls command is successful executed but doesn't show any in my files contained in /var/www/ftp. I suppose that this is because the ftp root directory is not set properly. Am I correct?


# cat /etc/vsftpd.conf

listen=NO
listen_ipv6=YES
anonymous_enable=YES
anon_root=/var/www/ftp/
local_enable=YES
write_enable=YES
anon_upload_enable=YES
anon_mkdir_write_enable=YES
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
chown_uploads=YES
chown_username=root
ascii_upload_enable=YES
secure_chroot_dir=/var/www/ftp
pam_service_name=vsftpd
rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
ssl_enable=NO
local_root=/var/www/ftp
  • What is the distro you're using? Do you have SELinux enabled? – mrc02_kr Oct 22 '18 at 11:28
  • I am on Kali 4.6. SELinux is not enabled – user123456 Oct 23 '18 at 9:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.